Game-devices-udev Install Failing

I’ve been trying to install game-devices-udev from the AUR with yay and I am getting the following error ==> ERROR: install file (endeavouros.install) does not exist or is not a regular file. I am selecting the clean install options and it deletes the cache every time.

I had this same exact issue. I ultimately got around it though by going to the gitlab page for game-devices-udev, and manually installing it with the instructions provided under “How to Set it Up/Others”. No clue why installing it directly from the AUR wouldn’t work, but the manual installation worked just fine. Remember to reboot your system after you are done.

1 Like

The only downside of doing it that way is not being able to automatically update it and having to go through those steps again.

Yeah, it’s not ideal…if someone comes up with a fix for installing it from the AUR I would love to just install it that way instead. But for now it works, and atleast i can use my steam controller again.

The AUR package is set for supporting only Arch, and the endeavouros.install filename is generated from the distro name:

install="$(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2).install"

Hence, it doesn’t directly install under EnOS (or any other derivative).


If I understand properly, editing the PKGBUILD to archlinux.install would allow us to install it.

1 Like


I don’t understand why people put such hacky things in their PKGBUILDs.

If you look at the os-release file on Arch Linux the last line of it is:


This is intended for programs like screenfetch to know which ascii logo to draw, and for similar things. It is obviously not the right place where one should look for a distro name.

Also, if some update changes the os-release file to include another line after the LOGO=... that will break it. It’s so hacky and unnecessary. :roll_eyes: