G-SYNC suddenly unavailable Lin+Win, no hardware change

Hello,

I didn’t touch anything at all in my hardware configuration in a long while. A couple days ago I noticed my monitor wasn’t in GSync mode anymore. No option in nvidia config panel.

I thought it was because of the kernel 6.x update, but today I had something to do in Windows, and… no option there either. So I’m pretty sure it’s a hardware problem, somehow.

Linux helpfully provides this in the logs:

kernel: nvidia-modeset: WARNING: GPU:0: AUS ROG PG279QM (DP-2): Failed to initialize G-SYNC

(My monitor is of course an ASUS ROG PG279QM, I don’t know why the kernel writes “AUS”)

What would cause a monitor or GPU to suddenly fail at G-Sync, specifically? Everything else still seems to work well. The DP cable seems firmly in place, and no, there is no other cable connected, and again, I didn’t touch anything hardware related in ages.

Any thoughts?

inxi:

System:
    Kernel: 6.0.2-arch1-1 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.26.1
      Distro: EndeavourOS
  CPU:
    Info: 12-core AMD Ryzen 9 5900X [MT MCP] speed (MHz): avg: 2316
      min/max: 2200/4950
  Graphics:
    Device-1: NVIDIA GA104 [GeForce RTX 3070 Lite Hash Rate] driver: nvidia
      v: 520.56.06
    Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4 driver: X:
      loaded: nvidia gpu: nvidia,nvidia-nvswitch resolution: 2560x1440
    OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2 v: 4.6.0 NVIDIA
      520.56.06
  Drives:
    Local Storage: total: 5.46 TiB used: 2.88 TiB (52.8%)
  Info:
    Processes: 374 Uptime: 8m Memory: 31.26 GiB used: 3.26 GiB (10.4%)
    Shell: Zsh inxi: 3.3.22

Try downgrading Nvidia drivers, both on Linux and Windows. You can use downgrade from AUR.

downgrade is on the EndevourOS packages…

1 Like

Thanks for the suggestion.

I hadn’t touched my Windows install in ages, so the drivers there were older ones, from when it definitely worked. (I upgraded them since to see if it solved the problem; it didn’t). :woman_shrugging:

On Win, neither hardware nor software had been altered; that’s what puzzles me…

Did you check the cable connections? :smile:

Oh, I re-read your post, sorry.

EDIT: does it work with the LTS kernel?

EDIT2: https://wiki.archlinux.org/title/NVIDIA/Troubleshooting
https://wiki.archlinux.org/title/NVIDIA
Maybe nvidia-settings could fix something?

Yep, I checked the cable :stuck_out_tongue:

I didn’t test it yet, good idea. I’ll do that next reboot. (I’ll be very confused, albeit pleasantly so, if it works on LTS)

That’s just the usual configuration interface; like its windows counterpart, it no longer offers any option related to G-Sync (which infuriates me; I’d rather have a greyed-out section, telling me explicitly “not supported / detected / error” or something, rather than having old memories of the setting being there, and searching screenshots on the internet to confirm I’m not crazy).

I had taken a look at the Arch wiki troubleshooting page before posting, and saw nothing relevant there :woman_shrugging:

I’m on LTS kernel, same error message, as expected, since it’s almost certainly a hardware problem.

Oh well, no big deal, I don’t need G-SYNC that much, I’d just like to understand why it spontaneously decided to go bye-bye, but I’ve too much on my plate right now to troubleshoot this further.

If I ever figure it out, I’ll update this thread. Cheers.

1 Like

Sorry to hear. Sounds like a hardware problem, so one idea to confirm it is to try change some related hardware if possible and see what happens.

1 Like

No worries, thanks for your help :slight_smile:

I’ll definitely try another DP cable if I get my hands on one, as well as see if changing the display mode in the screen’s firmware changes anything (Racing / Eco, etc).

I’ll also do a full poweroff to fully reset the GPU (I occasionally have LED problems on the card that can only be resolved by cutting power until its capacitors are empty, otherwise they persist across reboots)

Swapping GPU or screen would of course be obvious troubleshooting steps, but too “expensive” (in time, energy, risk,…) given how minor the problem is. Given that the monitor is 240 Hz anyway, I’m not at all sure I could tell whether G-Sync is activated or not in a blind test. :laughing:

1 Like