Functionality of F1-F12 keys does not work

After installation, the functionality of the F1-F12 keys does not work. Earlier, when there was mkinitcpio, I quickly solved this problem, but now in endeavorOS mkinitcpio was replaced with dracut and now what I did before does not work.
My keyboard has a 68% layout and in order to use the F1-F12 functionality of the keys, I use the combination fn + 1 = F1 for example.

What was the solution you used with mkinitcpio?

earlier on the path /etc/modprobe.d/hid_apple.conf I just wrote the following: options hid_apple fnmode=2. After that I rebooted and everything worked, but not now.

Try adding a config to /etc/dracutconf.d/ like described here:

Then rebuild the initramfs and test again.

it doesn’t work too

Finally it worked, though in /etc/dracut.conf.d/hid_apple.conf I added: install_items+=" /etc/modprobe.d/hid_apple.conf " That is, just with quotes and spaces at the beginning and end of the path, unlike from the instructions you provided. Next, I updated the system, rebooted and this eventually solved the problem.

Ah you are right, the quotes and the leading/trailing spaces are the correct format for a dracut config. I didn’t notice those were missing when I saw that post on the Fedora forum, good eye. Glad to hear you got it working! :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.