Fullscreen YouTube video tearing and no nvidia-settings to help

I have followed these tutorials on the EndeavourOS website:


I installed the dkms nvidia driver with the nvidia-installer-dkms.

Everything worked fine I guess. I have no v-sync problems on the desktop environment, running apps, moving windows around or even playing full-hd videos on VLC.

But when I play YouTube videos in full screen, I get some very noticeable screen tearing issues.

I tried following the arch wiki’s “nvidia vsync troubleshoot” guide as well as setting layers.acceleration.force-enabled to true inf firefox’s about:config. Nothing worked!
I also noticed that the nvidia-settings program always answers with ERROR: Unable to load info from any available system even though I think the nvidia drivers are installed.

How do I get proper vsync on youtube?

Thank you for your time, bellow I’ll post some useful info:

$ dkms status                                                           
broadcom-wl, 6.30.223.271, 5.8.14-arch1-1, x86_64: installed
nvidia, 455.28, 5.8.14-arch1-1, x86_64: installed

$ lspci -k | grep -A 2 -E "(VGA|3D)"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
	DeviceName:  Onboard IGD
	Subsystem: Dell Device 07d1
--
01:00.0 3D controller: NVIDIA Corporation GM107 [GeForce 940MX] (rev a2)
	Subsystem: Dell Device 07d1
	Kernel driver in use: nvidia

$ nvidia-settings --query CurrentMetaMode
ERROR: Unable to load info from any available system
ERROR: Unable to load info from any available system

$ neofetch                                                      
OS: EndeavourOS Linux x86_64 
Host: Latitude 5580 
Kernel: 5.8.14-arch1-1 
Uptime: 31 mins 
Packages: 1168 (pacman) 
Shell: zsh 5.8 
Resolution: 1920x1080 
DE: Budgie (git-10b814fa62bf774ca48e 
WM: Mutter(Budgie) 
Theme: Arc-Dark [GTK2/3] 
Icons: Arc-X-P [GTK2/3] 
Terminal: mate-terminal 
Terminal Font: Monospace 10 
CPU: Intel i7-7820HQ (8) @ 3.900GHz 
GPU: NVIDIA GeForce 940MX 
GPU: Intel HD Graphics 630 
Memory: 2187MiB / 15647MiB 

$ cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "AccelMethod" "uxa"
  Option "TearFree" "true"
  Option  "TripleBuffer" "true"
EndSection

$ cat /etc/X11/xorg.conf.d/20-nvidia.conf
Section "Device"
    Identifier "Nvidia Card"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
EndSection

Section "Screen"
        Identifier      "nvidia"
        Option         "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

        Option          "TripleBuffer"                  "on"
        Option          "AllowIndirectGLXProtocol"      "off"
EndSection

When I get home I might be able to help with this. FF + YT on Linux is kinda a dumpster fire for Vsync

Which browser are you using? Firefox, at the moment, is not ideal to watch videos, like @Echoa already said. Just try, for testing purposes, one of the chromium-based browsers or Epiphany if you’re really against Chromium-based, though it will not show DRM videos. (Netflix etc.)

I just realized i think youre running a prime system like a laptop no?

You might need a different driver/driver setup and might need to force firefox to use a specific GPU. Vsync when you have multiple GPU can be weird, check firefox about:support to see what GPU its trying to use.

not sure if OP is still looking at this thread or not but i found what might be going on

so i installed regular firefox and for the life of me couldnt get screen tearing to stop on the plain jane version

I havent used that in a while what i use it the Developer edition and this is how i fix it

go to about:config
change these options

gfx.webrender.all = true
layers.acceleration.force-enabled = true

you may need to reboot after these as ive had it not work till a reboot after first setting them but ymmv

put these settings to /etc/enviroment and restart

__GL_YIELD=“USLEEP”
KWIN_TRIPLE_BUFFER=1
KWIN_USE_BUFFER_AGE=0

This will take care of all tearing in kde plasma

OP is on budgie which I think is some variant of mutter

I’m on gnome and previous post works for me

Does this work for Intel graphics too? I notice screen tearing on Intel, but no with prime render offload with nvidia.

I never had intel graphics, but give it a try

Doesn’t seem to work for Intel. Getting bad tearing just by dragging windows.

Too bad, but now we know

for intel you could set vsync from auto to “full screen repaints” in compositor settings in the system settings of kde…

you might need to enable tear free if using xorg on intel