Full system freeze before login on boot

Hello! Posting to ask about a breaking issue. I’m on EOS, on an ASUS TUF A15 FA506QM laptop, with the latest linux-g14 6.8.1 kernel (see asus-linux.org), using Plasma 6 with Wayland (if relevant).

For context, prior to this, I was having issues with frequent random kernel panics at boot or shutdown. I didn’t do too much about it because I was told it was possibly a kernel regression and it was likely to be fixed in the next linux-g14 update (I don’t think it was but not super relevant; I am fairly certain the current freeze is NOT a kernel panic).

Then one morning during class, I got a kernel panic during normal usage, and more specifically in the middle of a system upgrade. When I forced shutdown and turned it back on, I saw this. Basically, it starts up, shows systemd messages and freezes on a black screen with a static _ before SDDM ever appears. You can see in the video that I try to access the other TTYs and can’t. I used to force shutdown out of this but I learned that simply pressing the power button does shut it down cleanly ; but that’s the only input I’ve been able to get through to it.

I’ve already tried a handful of things to no avail :

  • Boot with the regular linux kernel instead of linux-g14. Same result.
  • Boot with either kernel using the initramfs fallback option on grub. Same result.
  • Add ibt=off to the grub entry and start that way. Same result.
  • Boot off an Arch live USB, chroot in and fix any broken packages. I checked if any were missing files with pacman -Qo. Some were and they were reinstalled but same result afterwards.
  • System upgrade. After fixing a small handful of “failed to commit transaction (conflicting files)” errors, done successfully; same result
  • Switch nvidia-dkms driver with regular nvidia driver. Same result.
  • Downgrade nvidia-dkms and related packages to 545 instead of 550. Same result.

I find myself lost on what to do at this point. Since I need my machine for uni, I was thinking of backing up my files through chroot and reinstalling EOS entirely, but if I can avoid it, and since there’s a non-zero chance this could be related to the issues I’ve been having since I started using Plasma 6 + Wayland, I would like to fix it.

This is a journalctl entry from a standard boot with clean shutdown. I don’t see anything obvious that would cause this and lack knowledge, so I have no idea what to make of it. Is there anything I can try? Thanks in advance.

i had this problem on my pc when i had arch 3 months ago but it was a little diffrent cuz it froze only if i had used it for 3 minutes so at first glance i would recommend installing the newset kernel with sudo pacman -Syu linux linux-headers but if you cannot get the system fully booted it wont work so if it cannot get booted fully then i recommend installing the whole system again so just back up any data that is crucial and go with the install process again but with the kernel 6.8.2