Fstab question

i have two extra hardrives on my pc. following tutorials I have edited the fstab file to automount one on boot. works exccept when I search for the drive in thunar its moved from under devices to the mnt folder where i pointed it to. id like it to stay under the devices tab. anyway to do this or did i do somthing wrong ?

I don’t trust myself to edit the fstab file directly, so this is what I always do:

  • sudo mkdir /mnt/nameOfBackupDrive
  • sudo mount -U UUID-of-Backup-Drive /mnt/nameOfBackupDrive
  • Use gnome-disk-utility to unmount the drive
  • sudo mount -o gid=users,fmask=113,dmask=002 /dev/sdbX /mnt/nameOfBackupDrive
  • Use gnome-disk-utility to automount the drive and to mount it using a label
  • sudo systemctl daemon-reload → reloads fstab file

The 3rd step is not always necessary for my drives, but one of my drives in particular always gives an error message that the drive is already mounted if I skip step 3.

EDIT: Just realised that I misinterpreted the issue. Though my suggestion should fix it, it’s probably unnecessary. :sweat_smile:

Perhaps “Devices” is reserved for whatever gets mounted externally, like removable devices (ext. disks, flashdrives…).

If you have mounted the drive onto a directory/mountpoint, I guess there might be a way to add it to the left pane in thunar. Right click on the directory and see if you get an option for adding it to the pane.

A partition I use for ‘extra storage’ on my HDD is also listed under “Devices”, so not exactly.

Do you automount it as well via /etc/fstab?

I guess? I use the method I mentioned in my first reply. Does that count?

The method you are using is rather quite new to me. I just edit /etc/fstab directly.

You could look into your /etc/fstab and see if you have any entry for it there and what mount option you use.

So perhaps, I should rephrase what I said before: Perhaps “Devices” is reserved for any device not mounted via /etc/fstab? Perhaps? Or I am just plainly wrong about it :blush:

Don’t remember where I found it, but I used to have trouble with my external drives mounting under /run/dev after each reboot. With this method, it mounts the way I want.

Here is my fstab because I’m not sure I understand your question:

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
 8 UUID=0159-62B2                            /boot/efi      vfat    umask=0077 0 2
 9 UUID=069db6da-8ee4-4859-9f72-487796ebbb04 /              btrfs   subvol=/@,defaults 0 0
10 UUID=069db6da-8ee4-4859-9f72-487796ebbb04 /var/cache     btrfs   subvol=/@cache,defaults 0 0
11 UUID=069db6da-8ee4-4859-9f72-487796ebbb04 /var/log       btrfs   subvol=/@log,defaults 0 0
12 UUID=c8d862cc-2236-442b-8ebf-6c40e47bb3be /home          btrfs   defaults   0 0
13 LABEL=BTRFStorage /mnt/BTRFStorage auto nosuid,nodev,nofail,x-gvfs-show 0 0
14 LABEL=SG-BKP /mnt/SG-BKP auto nosuid,nodev,nofail,x-gvfs-show 0 0
15 LABEL=T7 /mnt/T7 auto nosuid,nodev,nofail,x-gvfs-show 0 0
16 LABEL=T72 /mnt/T72 auto nosuid,nodev,nofail,x-gvfs-show 0 0

I just wanted to see what mount option you have used in gnome-disk-utility to create the entries in the fstab.

This: x-gvfs-show might be what OP needs to add to the mount options, I guess.

Oh, I see.

The Devices tab only show root partition “/” and disks that are not mounted through /etc/fstab.
You can add your mount point in Places, right click on the directory, “Send To → Side Pane”.

My internal drives in /etc/fstab look like this :

UUID=55a672a6-3c04-4af3-9ea3-bf519f730b9c /MEDIAS    ext4    defaults,noatime 0 2

For me, both Nemo and Thunar show removable devices under the “Devices” section. Only Dolphin shows it separately in the way that you stated.

PS: I reinstalled Thunar just to see if it’s different. I don’t actually use it anymore. It’s gone now.

I’ve been investigating that some time ago for Gnome and what I found out was ‘Devices’ section is preserved for devices that are being mounted in /run/media/user/device (default mountpoint for devices like usb and hard disks as well), once you have moved your mount points using fstab to /mnt directory, they’re no longer visible under ‘Devices’ section in Thunar. Plasma and its Dolphin offers to manually create a shortcut of any kind under ‘Devices’ section, IDK whether that’s also possible in XFCE’s Thunar.

This doesn’t exactly line up with what my visual example of all three shows. But maybe there is just something different about my particular setup that would make your findings not apply. :thinking:

OP - if you still need help you would need to post yout fstab

i forgot all about this ill be working on some of these suggestions soon. sorry about that