Fresh install with Plasma 6 missing AMDVLK

Hey o/
I thought this was interesting, so I figured I’d share.

Just did a completely fresh install of EndevourOS (Galileo-Neo-2024.01.25) selecting Plasma from the installer. Everything goes great, Plasma 6 comes up right away (and looks great btw) and everything seems to be fine.

But the graphics won’t initialize. vkgears fails, vulkaninfo complains about missing drivers. So I quickly check and sure enough, no AMDVLK installed. (Using a 6700XT) I do a sudo pacman -Sy amdvlk lib32-amdvlk and poof, everything is up and running.

I’m sure this worked just fine by default back in the olden days (of a few days ago) when Plasma 5 was the default. Was this always meant to be like this or am I hallucinating? xD

You should use vulkan-radeon instead of amdvlk. The former is much better supported, is more compatible and generally offers more consistent performance.

As for installing the correct vulkan drivers for every piece of hardware, that it beyond our current hardware detection capabilities in the installer.

1 Like

Oh thanks. For some reason I was thinking vulkan-radeon was for older hardware, and amdvlk was more modern. Not sure why.

I guess the reason I may not have run into this on previous installs is that something else I installed added the driver as a dependency. Maybe Steam does that? I guess I just associated it with Plasma 6 since that was the big change this time.

Yes Steam will give you several options to pull in amdvlk / vulkan-radeon as well as the lib32 component of the correct package.

1 Like

Yea that makes sense then. The game I usually use to try out the graphics is on steam. I just kind of randomly typed vkgears this time for no particular reason.

Also just swapped to vulkan-radeon, and it just solved a couple of problems I’ve been dealing with for ages now. Definitely sticking with that one.

1 Like