Fresh install no sound (laptop) Alder Lake PCH Audio

I might be the millionth person with this problem but here goes…
I’ve done a fresh install and am not getting any sound from my laptop. LiveCD worked.
I should add, if I plugin a USB-C earphone with microphone, it works fine.

I’ve tried installing sof-firmware, lts/zen kernel and I’m still getting nothing.

Here’s the inxi -Fxxxza --no-host output

  Kernel: 5.15.39-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=505c6d91-ae75-445f-b5c0-58d0b07056ce rw rootflags=subvol=@
    quiet resume=UUID=d13f7c7a-17a5-4269-b47e-b55bb74eef7d loglevel=3
    nowatchdog nvme_load=YES
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 dm: LightDM v: 1.30.0 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: SAMSUNG product: 950XED v: P05RGF serial: <filter>
    Chassis: type: 10 serial: <filter>
  Mobo: SAMSUNG model: NT950XEW-A51AS v: SGLFREEDOS-C00-R000-S0000+1.0.0000
    serial: <filter> UEFI: American Megatrends LLC. v: P05RGF.044.220307.ZQ
    date: 03/07/2022
  ID-1: BAT1 charge: 30.5 Wh (45.0%) condition: 67.8/66.8 Wh (101.4%)
    volts: 16.0 min: 15.4 model: SAMSUNG Electronics SR Real Battery
    type: Li-ion serial: <filter> status: charging cycles: 7
  Info: model: 12th Gen Intel Core i5-1240P socket: U3E1 bits: 64
    type: MST AMCP arch: Alder Lake family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x41C
  Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
    cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB
    L2: 9 MiB desc: 4x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 681 high: 1056 min/max: 400/4400:3300
    base/boost: 1584/4400 scaling: driver: intel_pstate governor: powersave
    volts: 0.7 V ext-clock: 100 MHz cores: 1: 486 2: 589 3: 616 4: 560 5: 579
    6: 557 7: 745 8: 870 9: 655 10: 580 11: 514 12: 541 13: 1056 14: 867
    15: 971 16: 722 bogomips: 67584
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Samsung Co
    driver: i915 v: kernel ports: active: eDP-1
    empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:46a6
    class-ID: 0300
  Device-2: SunplusIT 1080p FHD Camera type: USB driver: uvcvideo
    bus-ID: 3-6:4 chip-ID: 2b7e:c556 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting alternate: fbdev,intel,vesa gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: Samsung 0x4159 built: 2020 res: 1920x1080 hz: 60
    dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.0.3
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Samsung Co
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.15.39-1-lts running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:5
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 238.47 GiB used: 63.49 GiB (26.6%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVL2256HCHQ-00B
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B
    speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: GXA7DK2Q
    temp: 43.9 C scheme: GPT
  SMART: yes health: PASSED on: 12 hrs cycles: 35
    read-units: 138,806 [71.0 GB] written-units: 926,865 [474 GB]
  ID-1: / raw-size: 221.38 GiB size: 221.38 GiB (100.00%)
    used: 63.49 GiB (28.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 221.38 GiB size: 221.38 GiB (100.00%)
    used: 63.49 GiB (28.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-4: /var/log raw-size: 221.38 GiB size: 221.38 GiB (100.00%)
    used: 63.49 GiB (28.7%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 16.79 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 44.0 C mobo: 44.0 C
  Fan Speeds (RPM): N/A
  Processes: 355 Uptime: 8m wakeups: 1034 Memory: 15.26 GiB
  used: 3.6 GiB (23.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 Packages: pacman: 858 lib: 240 Shell: Bash (sudo) v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.15

It seems that with this hardware there have been a number of users with the same issue.

I can’t seem to find a good solution. Any suggestions?

None that have worked on this one.

While reading, somewhere I found that switching to latest Kernel may help. Along with this, using latest version of firmware-sof-signed was the recommended tips.
What is your take according to your knowledge ?

For kernels, tried: base kernel 5.17.5 - 5.17.7, linux-zen 5.17.5 - 5.17.7, linux-lts 5.15.39
Firmware-sof is installed (not sure about firmware-sof-signed) but no dice, unfortunately.

(post deleted by author)

Somewhere here, it is written that kernel is trying to use wrong module.

Why don’t you switch your sound server to PulseAudio and see if it works? You can use this guide from :enos: wiki.

Remember to restart your computer after switching to PulsAudio.