Fresh install, no audio on laptop

Using an Asus GL753VD, I have used linux distros in the past including endeavour os and never had this issue. I would think its an hardware problem then, but it worked fine on windows, never gave me any issues.
Tried installing eos gnome, and on startup audio wouldnt work, went through restarting pipewire, pipewire-pulse, removing pp-pulse and installing pulseaudio instead, removing pipewire altogether - before that just disabling pipewire, removing config folders for pulse and wireplumber and reboot, but nothing.
It may cause it to work upon reboot, but upon another reboot its back to not working again. I don’t know what to do about it

Just clarifying, when you say you’ve used Linux in the past with no issue etc etc, do you mean you’ve used it before on this specific laptop with no issue?

Next point of clarification, are you experiencing this issue on both speaker output, and when you have a pair of headphones plugged in? (a common point of difference)

Have you tried booting with the LTS kernel? This is particularly relevant if Linux and audio used to work on this laptop before.

Lastly, you might consider sharing your bootlog, to see if it presents some clues.

journalctl -k -b -0 | eos-sendlog
1 Like

Yes, I have used this specific laptop on like a dozen linux distros something like a year and a half ago, with absolutely no issues. And my sound card has full support aswell, cause its one of those sound cards that has a gazillion configurations available from pavucontrol, and they were all functional (It worked when trying 7.1 surround, for example)

My sound card basically appears as one single audio device regardless of if im using headphones or the integrated speakers (behaviour found on windows aswell)
To use headphones or to use speakers is the difference between having the jack cable plugged in or not. But the thing is the sound card is not recognized at all by the system, so that does not make much of a difference.

At this point in writing i went and tried to install the lts kernel, and at first boot up, it seems to work just fine. Will report if it breaks again upon reboot.

Is this something i should report somewhere? or is it a normal bug that can be ironed out?

Also one thing that could be of interest, using the regular kernel at boot up i could see some kind of "ACPI BUG"s, that booting with lts i did not see.
Maybe that was the cause for the audio to not work?

Either way thank you for reccomending me to install the lts kernel. One last thing is, are there any features i would miss out from by using the lts kernel? And how could i know in the future if/when my issue is fixed? Thank you.

I asked because I, and many other Linux users have had that issue with their laptop audio (headphone jack works, speakers don’t). It’s a thing.

Possibly. I dare say we’ll need some more details though in order to assist more meaningfully (eg: the bootlog under standard kernel).

I had some kind of the same issue with my Asus Rog Zephyrus G16. The combination between nvdia and the kernel seems to be the culprit in my case. With different kernels (lts, asus-linux, official) the sound wouldn’t work over speakers but over jack.

The current combination: nvidia 555 beta + linuxg14-kernel (6.9.5-arch1-1.1-g14) works fine.

Did you try to follow the guide over at

i will try to follow that, but no i’ve never had any issues in general so i never thought of following any kind of guide