Fresh install, booted, updated and now it can't find disk

So, just installed KDE Plasma next to Windows.

Worked like a charm, logged in after the fresh install, updated my system and installed packages etc. and all that fun stuff, and now after a reboot I see the following error:

I tried to cat /etc/fstab but nothing happens after typing that command, not even a error. Same with nano.

How can this happen?

You haven’t gotten far enough in the boot process for that.

Can you boot off the ISO, mount that partition and share the contents of /etc/fstab

First we need to figure out what happened, then we can work on how. :wink`

Currently trying to find out how to mount the disks.

They are LUKS encrypted and unencrypting with GPARTED doesn’t help.

But I did saw that the UUID unencrypted is correct.

sudo cryptsetup luksOpen /dev/whatever myluks
sudo mount /dev/mapper/myluks /mnt

Replace whatever with your luks device.

1 Like

This is what is in the fstab of the root partition:

What does the top of /etc/default/grub look like?

Now, that is interesting. And there is also a .bak.

Left = new right = bak.

That is definitely the issue.

Your GRUB_CMDLINE_LINUX_DEFAULT was replaced with ""

Try putting that line back in the file, chrooting into your install and running sudo grub-mkconfig -o /boot/grub/grub.cfg

Will do, and now that I see it, it hits me, my script that installs packages for me etc. also does that tweak.

I believe it was so that I can see all the terminal lines during boot.

But clearly now that I switched over to LUKS, that is a problem.

1 Like

Yes, instead of setting it to "", you should use sed or similar to remove the options you no longer want there.

Fixed, thanks a lot!

And got some new notes added to my Linux documents so if I need to do any of this stuff in the future I got the commands.

2 Likes