Fresh Galileo install can't get Wayland to work? GPD Win Max 2

I just installed a fresh version of galileo on my laptop and cannot get wayland to work.

When I select wayland in the login screen and try and log in it goes to a blinking curser at the top left for 5 seconds, then it goes straight back to the login screen. When I select X11 it works like normal though.

System specs:

GPD Win Max 2 laptop with 6800u cpu and integrated gpu.

Try early KMS loading admgpu as described in the wiki.

Don’t forget to run sudo dracut-rebuild after adding the config file.

Holidays here. Downloaded the latest ISO, chose KDE offline (as I am about to switch from Gnome anyway) and installed `plasma-wayland-session. The Wayland session can’t be started from SDDM with the exact same behaviour as described by @icedigger

Intel integrated GPU here. Never had issues with Wayland from Gnome or KDE in the past.

  • If I select a different display manager like GDM, starting the Wayland Plasma session works.
  • If I CTRL-ALT-F3 into VT3 and run startplasma-wayland the Wayland session also works.

So it’s SDDM which can’t start a Wayland Plasma session.

I am happy to share any log files.

If gdm worked for sddm might try

So two weeks later no update for sddm and still no way to start wayland from sddm. How can I report bugs upstream? I do not even know where the error message as why the session fails to start can be collected.

Do you have command
exec startx
in your ~/.bash_profile?
If so, remove it.

$ pacman -Q | grep wayland
kwayland-integration 5.27.10-1
kwayland5 5.114.0-1
plasma-wayland-session 5.27.10-2
qt5-wayland 5.15.12+kde+r61-1
wayland 1.22.0-1
wayland-protocols 1.32-1
wayland-utils 1.2.0-1
xorg-xwayland 23.2.3-1

Above are all the packages necessary to run wayland on KDE Plasma. Make sure you have them all installed.



Hero of the day! I commented out startx and now I can start buttery smooth from sddm without the crutch Ctrl-Alt-F3, login on the terminal and executing startplasma-wayland

Seems like a packaging issue then worth to be tackled? I genuinely wonder why no one else stumbled into that issue.

Thank you for your response, I do NOT have wayland-protocols installed.

As I do not witness any issues when working with wayland, I will not blindly install this dependency for now.

1 Like

It has been fixed for the next ISO. The issue was a wrong config file was copied to the target when installing offline. X11 worked OK but wayland didn’t.

1 Like