French accent in password on login screen issue

Not sure if this is really a bug or a missing configuration on my side, so do not hesitate to re-tag my post.

I just finished a fresh new install of EOS. During the installation process, I set up my keyboard with french layout, and I could correctly enter a password with accents in it (like ¨).

Yet, when typing my password on the login screen (I installed Gnome desktop if that matters), I can’t get the corresponding key to work. The visual/virtual proposed keyboard (accessibility options) doesn’t provide the needed symbol.
Same result if I try on a TTY instead.

I didn’t get this issue with other Linux distributions (e.g. Ubuntu 20 or Debian 11).

Anybody faced the same issue ?

On TTY, can you use command setxkbmap with the proper layout name (assumably fr)?

I guess you want me to type this command once logged within TTY ? But as I said, I can’t login even on TTY because it doesn’t understand the accent key input neither.

Sorry, i should’ve read your post more carefully.

What should work is use the USB installer and arch-chroot into the installed system. Then you can change the password temporarily and login normally and see if the locale and keymap is ok, or change the keymap.
The EndeavourOS wiki has articles about arch-chroot.

No worries, I’m glad you help !

I could arch-chroot using my live usb (the eos wiki tutorial was neat, it even provided example commands when having encrypted partition !), and changed my password.

After rebooting, I can successfully log in with a simpler password.

Locale seems OK :

System locale: LANG=fr_FR.UTF-8
VC Keymap: fr
X11 layout: fr
X11 Variant: oss

When looking for the keymap (setxkbmap -query), I’m unsure:

WARNING: Running setxkbmap against an Xwayland server
rules: evdev
model: pc105
layout: us

I don’t know why I’m using Wayland instead of Xorg (didn’t ask about it during the installation).

Also, I don’t know why it tells me my layout is us as the layout seems clearly french, and when checking settings in the GUI I do have only one layout activated which is french (variation).

Besides, I can type my original password (with the french accent symbol) in the shell.

Looks like either some wayland setting is not fully correct, or wayland has a problem setting the keyboard layout.
AFAIK, Gnome is using Wayland by default. I’m not using Gnome, but I assume you can start an Xorg session instead of Wayland at login.

Have you tried this already?

When using Wayland, you may need to specify the X keyboard layout manually with localectl(1). In the example below, a French layout is set.

# localectl set-x11-keymap fr


1 Like

I tried login using Xorg instead of Wayland, and I do have a different output when executing setxkbmap -query:

rules: evdev
model: pc105
layout: fr, fr
variant: oss,oss

Yet, at login screen, I still can’t use the ¨ symbol (nor ^ which is on the same key), but I can use some.

@pebcak I didn’t, thanks for the hint ! Just tried it but it doesn’t change the output of setxkbmap -query when using Wayland session. And doesn’t solve the issue on login screen neither.

Not sure if this would help but try activating the on-screen keyboard on the Login screen and see if you can input those symbols. Click on the icon of the person on the bar and toggle on the on-screen keyboard.

I already tried that but the on-screen keyboard doesn’t provide this symbol. I’m confused why the keymap seems to be correct once the session is started, but not on login screen, for few symbols (I do have the french layout on login screen based on the position of other symbols).

There a utility loadkeys in package kbd. In TTY it should work and be able to set the correct keys.

loadkeys fr

It might not be a solution, but worth trying if it helps anything, or even lead to the root cause of the issue.

Note also that I don’t have a French keyboard so I can’t really test it here.

While at it, can you show the output of command


loadkeys fr when executed in TTY outputs (tried to translate it from french) :

Keymap 0: Permission denied
Keymap 1: Permission denied
Keymap 2: Permission denied
KDSKBENT: Operation not permitted: could not deallocate keymap 3

I tried with sudo but it outputs nothing, and I still can’t use the ^/¨ key

As for the locale command, here is the output :


Oh, and btw, I can only access TTY4, and once I’m into it, I can’t exit with any combination of Ctrl + alt + Fn. Don’t know if this is related…

At least the locale output looks OK as far as I can tell.

Otherwise I’m currently out of ideas, sorry. Hopefully someone will chime in to help.

I can go check if this is general issue with GDM … hard to check in french but in german we have some nice öäü i can try…

Thank you for investigating this issue. Do you think it is worth trying to install another desktop manager such as xfce to see if this leads to a change ? Or it has nothing to do with this issue of “dead” key in the prompt of login screen ?

Just to let you know that I tried to change the graphical session manager through the welcome application. Switched from gdm to lightdm and I can now type ¨ or ^ symbols in the login prompt !

So this is an issue with gdm ? I checked on another machine (Ubuntu 20) on which I never had this issue but it looks like the default manager with Ubuntu is lightdm as well.

1 Like

Hi @Beinje!
For the developers to have a chance to look into this issue and hopefully fix it in some coming release, could you consider reporting it using the following link?


So it works with lightdm and wayland? Interesting.

And I think the idea of reporting this issue to the Gnome devs is a good one.