Freezes going to sleep

I just installed endeavouros yesterday and im having an issue where when i tell the computer to sleep, it freezes. the screen goes partway into the login screen, and then everything is unresponsive. i am able to REISUB but the mouse and keyboard don’t do anything otherwise.
when i run inxi -Fxxc0z i get:


Kernel: 6.6.23-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
Distro: EndeavourOS base: Arch Linux
Type: Desktop Mobo: Gigabyte model: B660M DS3H DDR4
serial: UEFI: American Megatrends LLC. v: F21
date: 11/15/2022
Info: quad core model: 12th Gen Intel Core i3-12100F bits: 64 type: MT MCP
arch: Alder Lake rev: 5 cache: L1: 320 KiB L2: 5 MiB L3: 12 MiB
Speed (MHz): avg: 800 min/max: 800/4300 cores: 1: 800 2: 800 3: 800 4: 800
5: 800 6: 800 7: 800 8: 800 bogomips: 52856
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: XFX
driver: amdgpu v: kernel arch: RDNA-2 pcie: speed: 16 GT/s lanes: 16 ports:
active: DP-3,HDMI-A-1 empty: DP-1,DP-2 bus-ID: 03:00.0 chip-ID: 1002:73ff
Display: wayland server: v: with: Xwayland v: 23.2.5
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu d-rect: 4480x2520 display-ID: 0
Monitor-1: DP-3 pos: primary,top-left res: 2560x1440 size: N/A
Monitor-2: HDMI-A-1 pos: bottom-r res: 1920x1080 size: N/A
API: EGL v: 1.5 platforms: device: 0 drv: radeonsi device: 1 drv: swrast
surfaceless: drv: radeonsi wayland: drv: radeonsi x11: drv: radeonsi
inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.4-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6600 (radeonsi navi23
LLVM 17.0.6 DRM 3.54 6.6.23-1-lts) device-ID: 1002:73ff display-ID: :1.0
API: Vulkan Message: No Vulkan data available.
Device-1: Intel Alder Lake-S HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel bus-ID: 00:1f.3 chip-ID: 8086:7ad0
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
API: ALSA v: k6.6.23-1-lts status: kernel-api
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
pcie: speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 06:00.0 chip-ID: 10ec:8125
IF: enp6s0 state: up speed: 100 Mbps duplex: full mac:
Device-2: Broadcom BCM4360 802.11ac Dual Band Wireless Network Adapter
vendor: ASUSTeK driver: wl v: kernel pcie: speed: 2.5 GT/s lanes: 1
bus-ID: 07:00.0 chip-ID: 14e4:43a0
Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 bus-ID: 1-3:3 chip-ID: 2357:0604
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: bt-v: 5.1
lmp-v: 10
Local Storage: total: 931.51 GiB used: 25.28 GiB (2.7%)
ID-1: /dev/nvme0n1 vendor: Western Digital model: WD Blue SN570 1TB
size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 serial: temp: 33.9 C
ID-1: / size: 579.39 GiB used: 12.05 GiB (2.1%) fs: ext4 dev: /dev/nvme0n1p5
ID-2: /boot/efi size: 96 MiB used: 26.7 MiB (27.8%) fs: vfat
dev: /dev/nvme0n1p1
ID-3: /home size: 119.97 GiB used: 13.2 GiB (11.0%) fs: ext4
dev: /dev/nvme0n1p6
Alert: No swap data was found.
System Temperatures: cpu: 33.0 C mobo: 29.0 C gpu: amdgpu temp: 33.0 C
mem: 30.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Memory: total: 32 GiB available: 31.19 GiB used: 8.97 GiB (28.8%)
Processes: 298 Power: uptime: 10m wakeups: 0 Init: systemd v: 255
default: graphical
Packages: pm: pacman pkgs: 1019 Compilers: gcc: 13.2.1 Shell: Bash
v: 5.2.26 running-in: konsole inxi: 3.3.33

please tell me if there is any other information i should post! i really need some help.

You are using wayland, does the problem occur with x11?

This problem has been fixed! Apparently, my wifi card was wreaking havoc on the system…the wifi card is outdated and i didnt have drivers installed for it (ive been using a wired ethernet connection but left the wifi card in because i didnt know it was going to be a problem) and this was causing problems with shutting down, rebooting, and sleeping. After removing the problematic hardware, these problems have been resolved!

1 Like

Great that it works now!

If you like tinkering: looks like it has a kernel driver wl and if I remember correctly, it is not always working well but an alternative should. Maybe blacklisting this (and maybe some other related) could help too, command lsmod should show which ones.
See also: man lsmod.