Freerdp: microphone w/ freerdp not working

A FreeRDP issue states that it has been compiled w/


How can I change the option w/o problems? How could the maintainers change the default for the package?

community/freerdp 2:2.1.2-1 [installed]
Free implementation of the Remote Desktop Protocol (RDP)


The problem has been fixed but somehow does not migrate to Arch/EndeavourOS. Any ideas?

Don’t know if this helps, but you can fetch the PKGBUILD and change it to your liking:

yay -G freerdp
cd freerdp

# edit PKGBUILD's build() function with an editor:

# Build freerdp, installs dependencies too.
# Installs freerdp if build was OK:
makepkg -cfs && sudo pacman -U freerdp*pkg.tar.*

Thanks! I have been looking for precisely these instructions. Let’s hope, it will be soon available for everyone, though.

1 Like

Sorry, I just noticed a small mistake in the pacman command. I’ll fix it a.s.a.p.
Edit: fixed. Pacman’s option must be -U instead of -S.

Thanks. I am waiting for it to migrate to Arch/EndeavourOS, too. Ubuntu already has it fixed. How to promote? Appreciate.

Maybe you could flag the package out-of-date?

So, I did. Let’s wait and see. :slightly_smiling_face:

1 Like