Framework 13: White Screen After Resuming From Hibernate

Hey all,

I’ve had EndeavourOS installed on my AMD Framework 13 for about 3 months at this point, and while this issue has cropped up during that time, I never thought to make a post about it. So, here I am.

The issue I’m running into is that sometimes my desktop environment KDE (wayland) will, upon resuming from either suspend to RAM or hibernation, displays a blank white screen. My cursor is still visible, and I can interact with my system, but I can’t see what I’m doing. I’ve been able to make several journalctl logs when it happens, but most of them were made before the update to Plasma 6. However, even with the update, the issue still happens. I’ve tried switching to the LTS Linux kernel and the zen kernel, but the issue still happens. This makes me think it might be more of an issue with Framework firmware, as I saw a few posts on the Framework forums describing a similar issue. I am on the latest firmware for FW 13, v3.03 I believe.

Here is a pastebin of a log I took yesterday after encountering the issue after resuming from hibernation:

System specs [neofetch output]:

OS: EndeavourOS Linux x86_64
Host: Laptop 13 (AMD Ryzen 7040Series)
Kernel: 6.6.22-1-lts
Uptime: 29 mins
Packages: 1605 (pacman), 13 (flatpak)
Shell: bash 5.2.26
Resolution: 2256x1504
DE: Plasma 6.0.2
WM: kwin
Theme: [Plasma], Breeze-Dark [GTK2], Br
Icons: [Plasma], breeze [GTK2/3]
Terminal: kitty
CPU: AMD Ryzen 7 7840U w/ Radeon 780M G
GPU: AMD ATI c1:00.0 Phoenix1
Memory: 3477MiB / 15175MiB

If there’s any additional information I can provide, please let me know. Thanks for reading!

I had a similar issue, I do not know the root cause but switching to X11 from Wayland on KDE fixed it for me. My main monitor would go white after hibernate/sleep.