Fractional scaling using gsetting

I am trying to enable fractional scaling on gnome 40 using gsettings but it doesn’t seem to be working. setting the option per the article below scaled my monitor back to 100% but i don’t see the option enable under display settings. & HiDPI on GNOME 40 - #8 by anon92247698

gsettings set org.gnome.mutter experimental-features “[‘x11-randr-fractional-scaling’]”

What exactly was the error?

It could be that the quote characters (" and ') on the command line are just incorrect.

You’re likely to find more reliable information directly on the Arch wiki,

If you don’t want to use xrandr then there are AUR packages that support fractional scaling for Xorg,

there is no error, the options to set it to 125% or 150% are not showing up.

If your GNOME session is not X11 but Wayland the setting is different: gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"
You also have to restart your GNOME session before the options appear in the settings application.

1 Like

Hi jafra,
for what it’s worth, I couldn’t get it to work either. Under Fedora 35 beta, the command:
gsettings set org.gnome.mutter experimental-features “[‘scale-monitor-framebuffer’]”
did show the additional scaling options but when I installed EndeauvourOS, it had no effect because of X11.
Regardless of what else I tired, it always ended up a mess and until someone has a working solution, I will have to run a different distribution or sell the 4K monitors and buy 1440p ones.

Update! I decided on selling the 4K monitors on craigslist. As of today, my whole setup is 1440p only (finally)! :slight_smile:

I feel your pain. Working with a 4K display is the one thing that gives me the most headaches. I use Linux pretty much full-time. To be specific the handling of fractional scaling is still not good with Linux desktop environments. It seems that there is still a popular opinion that “HiDPI support” means 200% scaling. I understand that values of 125%, 150% and 175% are technically much more difficult than just doubling. But this is 2021 and 4K displays are not some exotic thing anymore. They have been around for many years now and are becoming more and more affordable.

I was trying various desktop environments for a while (GNOME, XFCE, Cinnamon, KDE).
GNOME + Wayland + 125% scaling worked fine. But with none “native” GNOME/GTK applications (Chromium/Electron based, Flatpaks) you have to hope they support Wayland at all or modify their .desktop files to use special command options to support Wayland. Otherwise those applications look blurry. And the inability of many GNOME applications to remember their window size drove me crazy.

For XFCE and Cinnamon I tried playing around with DPI settings (120 or 144 instead of 96). But that made everything look strange. Buttons, fonts, window manager elements did never scale in the same way. Qt apps needed extra care to match the DE (qt5ct, kvantum). Cinnamon does have a scaling option but everything other than 100% or 200% resulted in bad performance.

The solution for me to this problem turned out to be KDE Plasma. I just use KDE with X11. Set the display resolution to 3840x2160 and “Global scale” to 150%. Font size 9 works OK for me (11 for fixed width). That’s it. No xrandr Kung-Fu. No fiddling with Xorg configuration files. No “experimental” feature (gsettings). It just works.
With every new Plasma release I try the plasma-wayland session and check how support for Wayland is improving. KDE is making a lot of efforts to support Wayland. The reason why I would like to use Wayland is because it supports separate scaling settings for multiple monitor setups. Right now with X11 if I set 150% scaling everything on my laptop screen becomes ridiculously large next to the 4K screen. But in practice I just turn off the laptop display and use the 4K screen exclusively.

If you really want to switch to a lower resolution screen I would suggest 2560x1440. I use two of those (Lenovo ThinkVision) at work in a dual-monitor setup. This resolution works fine for me with the traditional 100% scaling (96 DPI) and any desktop environment.

I used the packages the were recommended above by [jonathon] and they seem to work so far.

1 Like