Fractional scaling on gnome

As the title says, how do I do it? The option simply isn’t there.
I have checked the settings app as well as the tweaks app to no avail.
100% scaling is so small, it’s murdering my eyes :frowning:

Any help is appreciated. Ss attached below.

Are you in an X11 session or Wayland?

https://wiki.archlinux.org/title/HiDPI#Fractional_scaling

3 Likes

Yes… now I remember. That’s actually how I got fractional scaling on my Fedora Gnome install on my laptop. I ran gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']" restarted and fractional scaling was available.

3 Likes

I only know fractional scaling exists, but no idea what it is used for or how it can be useful because I don’t even use normal scaling since I always keep it at default 100%. :rofl:

Works for me on my laptop. Just makes things bigger and easier to see. Especially when I’m used to my desktop monitor at 32".

1 Like

I would recommend you to adjust font scaling via GNOME Tweaks rather than using fractional scaling. You could change it to 1.20 so that you would get a convenient scale.

The only scaling available in Tweaks is for fonts. That’s not the same as scaling the entire desktop.

Yes, that’s what I meant. Not the same thing as fractional scaling but can be seen as an alternative.

1 Like

I am finding a way to get it to 75% actually

wayland session.

1 Like

I’ve already done this to fix the fonts. As someone said, it doesn’t fix the system wide issue. I was rather surprised to not see fractional scaling enabled in the first place.

Thank you. It works like a charm! :smiley:

Followed your guide, fractional scaling available on restart. Thanks a ton! :smiley:

1 Like

Glad your issue is resolved!

Please consider checking the solution box under the actual post giving the solution.

Done. Thank you for the reminder.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.