Force Cinnamon to Use Xorg.conf

Hello! I wanted to know, how I can force Cinnamon to use Xorg.conf for my multi-monitor setup. I use nvidia-settings to setup my xorg.conf file. On Plasma, it is quite easy. I just disable K-Screen. On Cinnamon, there was an option to disable the xrandr plugin in the Autostart. It is no longer there.

In Cinnamon, the display settings are typically managed by the “cinnamon-settings-daemon” process, which uses xrandr for screen configuration. If you want to force Cinnamon to use your custom xorg.conf file for your multi-monitor setup, you can try the following steps:

  1. Disable Cinnamon Settings Daemon:
    You can try disabling the Cinnamon Settings Daemon and rely on your custom xorg.conf file.

    Open a terminal and run:

    cinnamon-settings-daemon --replace --no-daemon
    

    This command will replace the running cinnamon-settings-daemon with a new instance, and the --no-daemon flag will keep it running in the foreground.

  2. Autostart Script:
    Create a script to run the cinnamon-settings-daemon with the --no-daemon option and place it in your autostart directory.

    Create a script, for example, custom_cinnamon_settings.sh:

    #!/bin/bash
    cinnamon-settings-daemon --replace --no-daemon
    

    Make it executable:

    chmod +x custom_cinnamon_settings.sh
    

    Move the script to the autostart directory:

    mv custom_cinnamon_settings.sh ~/.config/autostart/
    

    The autostart directory may be different depending on your setup. You can also check ~/.config/autostart/ or /etc/xdg/autostart/ for system-wide autostart scripts.

    This script will replace the default cinnamon-settings-daemon with your custom one at startup.

  3. Update MATE Configuration:
    Cinnamon is based on the MATE desktop environment, and sometimes the settings daemon may be shared. You can try updating the MATE configuration as well.

    Create or edit ~/.config/mate-session-manager/session-properties:

    [Desktop Entry]
    Name=Custom Cinnamon Settings
    Exec=/path/to/custom_cinnamon_settings.sh
    Type=Application
    

    Replace /path/to/custom_cinnamon_settings.sh with the actual path to your script.

    Reboot or log out and log back in to see if the changes take effect.

Remember that forcing Cinnamon to use a custom xorg.conf might have some side effects, and it’s recommended to have a backup or a way to revert the changes in case something goes wrong. Additionally, consider checking the Cinnamon and NVIDIA forums for any updates or community-driven solutions related to this specific issue.

1 Like

Thank you, sir. I am amazed that you gave this reply. I asked this on the official Linux Mint forums and they didn’t help me the way you did.

Even that arch wiki hasn’t been updated. It still asks the users to use the old disable cinnamon-settings-deamon-xrandr trick to get Cinnamon to respect xorg.

I am very curious to hear how did you find this solution. it isn’t even provided by Mint.

1 Like

Too many hours spent in front of my screen.

If it solved your issue, please mark the post as ‘solved’.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.