Force 2 apps to communicate with each other even if Wayland doesn't allow it?

Hi friends, I’ve been trying to fix the following problem on my EOS for over a year now:

I have JDownaloader2 downloaded on my EOS from the AUR repositories. I can copy links without any problems and JDownloader will grab them without any problems in X11, but it won’t work if I do it from Wayland.

I also have problems copying/pasting in Steam chat, either with right click or ctrl+v, although clicking the mouse wheel does work. Sometimes it pastes older/previous links though.

Searching for information on the internet, I found that this problem is caused by Wayland’s strict security, which doesn’t allow communication between apps.

I can still use X11, but I’d really like to be able to use Wayland if possible. And I use JDownaloder every day, so it’s a bit annoying to have to switch between X11 and Wayland, so I’d like to know if this can be fixed somehow.

I thought the problem might be with the clipboard, but it seems that’s not the problem. I’ve tried copying the links directly into the “LinkGrabber” tab of JDownaloder 2 (it’s another method that should work), but JDownloader freezes for 30 seconds when I press ctrl+v or right click, and JDownaloder doesn’t get the links.

So, is there a way to break that security between apps in Wayland, and allow me to paste download links inside JDownaloder?

My goal is to be able to paste links inside JDownaloader2 in Wayland.

Do you think there’s a way to get this done?

Thanks from namteano for your help.

My suggestion would be talk to the app developer. Maybe he or she would want to make their application work in Wayland?

1 Like

Thanks friend, but unfortunately I did this a year ago on the official JDownloader 2 forums, and they told me that this was the fault of JAVA compatibility in Wayland, and that JAVA should take care of this.

But I’m sure there has to be a way for JDownloader to access those links, somehow.

I’m not 100% sure it’s a problem with JAVA.

Well that’s not abnormal, everyone pointing fingers in the other direction :slight_smile:

Yeah, who knows…but someone has to work on it, or it will be irrelevant in a fairly short order as distributions stop shipping X11 (soon).

1 Like

Well, I’ve been testing all day, it’s not the perfect solution, but I think it works:

I completely disabled the KDE clipboard, opened JDownloader 2, copied a link from Firefox, and the link capture confirmation popup does not appear most of the time, but the link is captured in the LinkGrabber tab. I also tried from Kate, and the same thing happens.

Also, in X11, when you capture a link, it takes a few seconds to be captured, but in Wayland it takes up to 1 minute, and as I said, the confirmation popup almost never appears, so you have to visually confirm that captured correctly.

Also, I don’t know if it captures all the links correctly, so there may be errors if multiple links are downloaded.

It’s not the perfect solution, but it seems to work a little. :expressionless:

I did a tiny tiny bit of research and some old reports said that OpenJDK is working on a wayland implementation…didn’t find anything to ever say it’s ready. Apparently java is limited to X11 and xwayland currently. I think you might have already known that ? Any way, that does support their assertion that it’s a Java problem (ie not there yet)

1 Like

Yes you’re right. I wasn’t 100% sure if it was a JAVA-Wayland issue, as I thought it might be the fault of the strict security of Wayland apps.

Although after having disabled the KDE clipboard, I can now paste text into JDownloader2’s “LinkGrabber” and into Steam chat.

I’ve read on Reddit that JAVA is quite stable and slow to implement new improvements (similar to Debian), so I don’t think they will implement support for Wayland anytime soon.

I have tried downloading various files with some default JDownlaoder2 plugins and everything seems to work fine. But you must have the “LinkGrabber” tab active so that it captures the links or right click and paste them (now it no longer freezes), it is a little uncomfortable but at least it works!

Thanks again for the information friend. : D