Font size too large in Sylpheed, Okular, etc

Some programs have very large fonts, e.g. Okular, Sylpheed, as well as the notifications (dunst). I’ve tried changing the font size using “Customize look and feel” but it doesn’t change anything.

I’m using a nvidia GPU. I used to use Endeavour without the GPU enabled in the bios and didn’t have this problem then.

Any ideas?

Cheers

Okular is Qt, Sylpheed is gtk2. those most likely need a bit of extra configuration. interesting why your gpu setting would affect it though

this is only setting gtk applications. And sylpheed is this gtk2 ? i think so? it needs ~/.gtkrc-2.0 to set up…
Configuration for Dunst:
~/.config/dunst/dunstrc

DPI settings could be changed ?

actually is “customize look and feel” lxappearance? iirc it sets gtk2 settings, it itself is written in gtk2

Thanks for the quick replies, you guys are on the ball!

I changed the font size in dunst config, but the notification font is still the same size after rebooting :face_with_monocle:

lxappearance (aka “customize look and feel” changes the font size of some things, e.g. Thunar, but not Sylpheed. Mildly annoying…

:wink: it does not set gtk2 settings…

1 Like
### Text ###

    font = Noto Sans Regular 11

is where you change it?

Can you share a screenshot?

Keep in mind that you are using a WM setup not a complete Desktop Environment from the same mould, so all tools and apps are not configured with such one for all tool, they are a base collection to start up with using a WM and set it up to your needs and wishes.

In case of qt apps you would need the same also inside most DE`s: https://discovery.endeavouros.com/applications/uniform-theme-and-fonts-for-qt-apps-in-gtk-environments/2021/05/

I never knew about that one! I always used lxappearance which configures gtk2 and gtk3 setings…

Here is my ~/.gtkrc-2.0 file. It looks like the file edited by lxappearance.

# DO NOT EDIT! This file will be overwritten by LXAppearance.
# Any customization should be done in ~/.gtkrc-2.0.mine instead.

include "/home/eireland/.gtkrc-2.0.mine"
gtk-theme-name="Arc"
gtk-icon-theme-name="Adwaita"
gtk-font-name="Noto Sans 9"
gtk-cursor-theme-name="capitaine-cursors-light"
gtk-cursor-theme-size=14
gtk-toolbar-style=GTK_TOOLBAR_BOTH
gtk-toolbar-icon-size=GTK_ICON_SIZE_SMALL_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=0
gtk-enable-input-feedback-sounds=0
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintmedium"
gtk-xft-rgba="rgb"

Thanks again. I did change that part of the dunst config. It is now:


    ### Text ###

    font = Noto Sans Regular 9

But still big. Not that this actually matters - mostly I just want the font smaller on Sylpheed, but here’s a screenshot with dunst.

I think the problem might be related to using two external monitors on a laptop, each with different screen size and resolution. When I entered

xdpyinfo | grep -B 2 resolution

the result I got was:

screen #0:
  dimensions:    3600x1080 pixels (636x191 millimeters)
  resolution:    144x144 dots per inch

…which is wrong (my monitor resolutions are 102 dpi and 90 dpi). I don’t want to start mucking around with monitor settings because nvidia has given me so many headaches in the past. It’s working now, which is the main thing!

1 Like

lxappearence (gtk2 version) sets both gtk3 and gtk2 settings here, and also the gtk3 version doing this now…

But I see the same issue with displays and different dpi settings, I do set mine up to fit their dpi so they look even, I see also a cursor size issue on multidisplay setups related to used dpi… where cursor show up huge on some apps…

1 Like

As @codic12 mentioned, Okular is QT, so you might need QT5CT to set your fonts there. I use a fair number of QT apps and got help getting QT5CT to work on Reddit’s i3 forum.

Thanks for everyone’s advice. I have found that simply entering a lower dpi this way solves my problem!

xrandr --dpi 100
1 Like

Glad you solved it, you can also create a sddm.conf file that fix it out too!
That’s how i was fixing it when i was using Plasma!

/etc/sddm.conf.d/dpi.conf

[X11]
ServerArguments=-nolisten tcp -dpi < your dpi>
/etc/sddm.conf.d/hidpi.conf

[Wayland]
EnableHiDPI=true

[X11]
EnableHiDPI=true

https://wiki.archlinux.org/title/SDDM
btw it’s working on every distros i’ve used , Void,Arch etc

2 Likes

Thanks. I might give that a try. I’m don’t have sddm though atm.

As weird as it sounds it was fixing even the non sddm dpi, desktop apps etc

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.