Font shows weird a's and letters instead of graphics \ designs

I’m new to EOS, and at first I didn’t mind it, but it gets really annoying. Whenever there is a terminal design, or anything of the sort (for example designs in lunar vim), it shows weird letters. Specifically, an a that looks like this:

It happens everywhere in the OS, and I mean everywhere. Even in outputs etc. So it’s getting kind of frustrating.

If anyone has any ideas I’d really appreciate it. I am using the i3 window manager, thank you everyone!

Change the font. Which terminal?

1 Like

xfce terminal 4 does that. I’ll try to change the font, but I don’t know if this is the reason seeing as it happens in Lunar Vim. Will try and update.

No problems here, xfce4-terminal to the right with firacode.

I tried to change my font but it won’t work for me :sweat:

It worked for me initially but now it just doesn’t haha, it’s really weird.

Very odd, can you post a full screenshot?

Sure. Of what?

lunarvim in terminal

just guess

:pray: never try lunarvim

Uh, I’ve seen that recently. It might be it to be honest, I’ll try and update.

Firacode is a nerdfont.

Thanks. I’ll try to download that and see if it helps :slight_smile:

Never understood the obsession with “Vim”, can’t the original program be used or a variation which doesn’t have a sign-on screen? From one of the screenshots, it looks like “Lunar VIM” was trying to display its logo but there weren’t enough characters across. The menu displayed just fine, from what it looks like, except the bullets.

Uh, of course it can. I use Vim because I’m comfortable with it.

The problem occurred in other places across the terminal, not only vim.

The font did not help. Any other ideas? :sweat:

What is your locale set to?

1 Like

Try looking through might be able to help.