Font Awesome Issues (especially powermenu)

tl;dr - what are the font-awesome packages installed by default in EOS i3?

I tried installing some different font-awesome packages to get some icons working in my bar, but apparently that borked some of the ones that display on the powermenu. I realized the cheatsheet online is for font awesome 5, but the config file mentions that it uses 4.7 I believe. Just need to know which FA packages are installed on a fresh install to fix what I messed up (hopefully).

Any other tips for getting more font-awesome icons working without disrupting the existing ones would be great - I wanted to use the openweather script on my bar but several of the weather icons aren’t displaying correctly, possibly because of the version differences.

awesome-terminal-fonts

Weird… I still have that package installed, but the power menu icons don’t show up correctly. I’d attach a screenshot but scrot doesn’t seem to work when I have the power menu displayed.

these awesome font packages are changing all the time… and can interfere with each other…

could need delay the scrot as powermenu will went of on focus other window

open a terminal write
scrot -cd 5
will give you 5 sec
open powermenu

1 Like

Thanks! Here’s a screenshot, Logout, Reboot and Shutdown aren’t displaying correctly, but they were when I first installed EOS:

powermenu

i use Font Awesome 6
and seems to work

1 Like

Interesting… I thought 5 was the latest version? Here are the font awesome packages that come up and the ones I have installed:

remove otf-font-awesome-4 ttf-font-awesome-4 and otf-font-awesome

1 Like

Hmm, that didn’t fix it, even with a logout/login. Removing those didn’t seem to change anything.

what does the power menu config look like ?

1 Like

have you tried downloading awesome font from their website ?

1 Like

I haven’t, but I can if that might help… I would think having the packages as they were by default would fix it, but maybe not

otf-font-awesome is causing issues currently… seems it screws the output in some cases…

i never use from repo
always use this

I removed that package, but I’m guessing it messed with something that effects the output when I installed it? Any idea how to fix?

I can certainly try that.

Still no change :expressionless:

At the end of the day it’s not a huge deal since the menu still functions, but it’s definitely annoying.

strange! i just copy (raw) from here

it work ok + icon work ok … i full updated (today)

this i have installed

community/ttf-font-awesome 5.15.4-1 (183.4 KiB 363.3 KiB) (Installed)
    Iconic font designed for Bootstrap
community/python-qtawesome 1.0.3-1 (708.1 KiB 1.8 MiB) 
    Iconic fonts in PyQt and PySide applications
community/otf-font-awesome 5.15.4-1 (435.2 KiB 1.1 MiB) (Installed)
    Iconic font designed for Bootstrap
community/awesome-terminal-fonts 1.1.0-4 (186.0 KiB 377.3 KiB) (Installed)
    fonts/icons for powerlines

2 Likes