Fn lock on boot


Im having an issue that consists in fn lock after boot. Every time i restart it turns itself on and i want it off. (Turns on the light)
On windows its the reverse, it boots off just like i want.
Is there anything I can do to prevent this?

1 Like

How is it set in the Bios?

Its enabled, i allready tryed all bios options

You tried it with it set to off in the bios? Did you save the settings before exiting?

It would be useful to have more information such as what you have installed? Did this happen as soon as you installed or is this a problem that just started after some updates. This is very limited information.

inxi -Faz | eos-sendlog

It started right after i install, and i think i have already tried all options possible, what can i do?

  Kernel: 5.16.13-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=1cada345-2b26-45d3-a382-ddab9505b94c rw quiet loglevel=3
    nowatchdog nvme_load=YES
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: ASUSTeK product: ZenBook UX425EA_UX425EA v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: UX425EA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: UX425EA.312 date: 12/03/2021
  ID-1: BAT0 charge: 25.7 Wh (43.0%) condition: 59.7/67.1 Wh (89.0%)
    volts: 15.9 min: 15.9 model: ASUSTeK UX425 type: Li-ion serial: <filter>
    status: Discharging cycles: 53
  Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake family: 6 model-id: 0x8C (140) stepping: 1 microcode: 0x9A
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 754 high: 1145 min/max: 400/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 549 2: 779 3: 958 4: 583
    5: 816 6: 611 7: 1145 8: 591 bogomips: 44864
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: ASUSTeK
    driver: i915 v: kernel ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4,
    HDMI-A-1, HDMI-A-2, HDMI-A-3, HDMI-A-4, HDMI-A-5
    bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-6:2 chip-ID: 13d3:56eb class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: compositor: xfwm v: 4.16.1 driver:
    X: loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP1 mapped: eDP-1 model: Chi Mei Innolux built: 2016
    res: 1920x1080 hz: 60 dpi: 157 gamma: 1.2 size: 310x170mm (12.2x6.7")
    diag: 354mm (13.9") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: ASUSTeK
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.16.13-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:3 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
    class-ID: 0104
  Local Storage: total: 953.87 GiB used: 9.28 GiB (1.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 004C
    temp: 33.9 C scheme: GPT
  ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%)
    used: 9.28 GiB (1.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 255 Uptime: 23h 54m wakeups: 16082 Memory: 15.33 GiB
  used: 3.44 GiB (22.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: pacman: 984 lib: 220 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.13

Are you sure that you haven’t pressed some of the keys that lock the fn key. such as fn + esc? Or it is another key combination.

what desktop environment are you using? Some have a setting to turn it off ('cause it’s on by default)

1 Like

On my HP laptop, it is possible to lock/unlock the Fn key together with shift key

i just put that in there for another place to look as it happens with cinnamon, and if it happens with cin, then it can happen with any de, so not necessarily bios specific (in the original post, it doesn’t happen in 10, but does with xfce, which would imply a s/w setting|)

It happens to me with all linux distros, and the desktop doesnt change nothing…
Only in Windows it boots off by default

Read the HW (laptop) manual about it.
Post what the Manual says exactly.

Edit: I found this:

Function keys

Press Fn+Esc to enable or disable the function keys feature.
When the function keys feature is enabled, you can also access HotKeys
by holding down Fn in combination with the top row keys.

Told the OP to check that earlier? :man_shrugging:

1 Like

I notice that this problem is mentioned here, but unfortunately the discussion does not offer a solution:

Although for a somewhat different problem, and for a different Asus model, you might try the solutions offered here:



If the solutions in the Arch Wiki don’t help, here’s another idea:

Apparently, one of the BIOS settings does work on this user’s Asus, but he’s forced to press Fn+Esc each time he boots up.

I’m thinking that if your experience is the same as this user’s, you might be able to run an autostart script, perhaps using xdotool, that issues the Fn+Esc keycode automatically, so you don’t have to press Fn+Esc manually each time you boot up.