Flatpak errors


This is a feature request and a bug (?) report at the same time:

  1. Could you please support Flatpak out of the box?
  2. When I run a Flatpack app (such as OnePassword) from the command line, I get a whole lot of CRITICAL logs like this:
(flatpak search:11362): GLib-CRITICAL **: 15:34:04.399: g_once_init_leave: assertion 'g_atomic_pointer_get (value_location) == 0' failed

Would be great if you consider implementing 1. For 2, let me know if you need more information.

Hi and welcome!

I’m not the one making decisions here, but the answer will be a no. Arch repo + AUR have everything most users would need.

They should be reported to the relevant repo. Many times they are harmless. But if you think they are hampering usage of application, report to upstream.


Welcome to the forum!

No, this is very unlikely ever going to happen. One of the best things about EndeavourOS is that it does not come with a lot of crap most users do not want.

Flatpak is in the repos, you can install it if you really want to.

Never heard of it. Where did you get this flatpak from?

This is almost certainly an issue with this specific flatpak, not with Qtile or anything else.

Is there a reason why you use this password manager (at least I assume it’s a password manager) and not something like KeePassXC?

1 Like

We all dislike flatpack, hate snaps and have a low opinion of appimages. Oh yeh and I personally abhor electron, though I run one! (Bitwarden).


We generally install a minimal system out of the box. Something like flatpak is easily added post-installation.

First, make sure your system is fully up-to-date with:

sudo pacman -Syu

If you installed software without updating you could be in a partial update situation which can cause all kinds of strange breakage.

If you are still getting the errors after that, please post the full output from the terminal including where you ran the command.

1 Like

Is this dislike of Flatpak unique to the Qtile flavor or an endeavouros-wide ideology/tenet?

Installing Flatpak using pacman or yay works, but is not as fine tuned as some other distros. For example when you run flatpak install ..., Pop OS will ask you whether you want to install the app for the current user or the whole system before proceeding with installation but on endeavour flatpak by default assumes you want to install packages system wide (unless you explicitly pass the --user flag).

Anyway. It is good to know that out of the box flatpak is not planned for this flavor. A pity IMHO, but understandable otherwise.

And regarding OnePassword (or more officially 1Password), you can google it, and you can install it directly:

flatpak install https://downloads.1password.com/linux/flatpak/1Password.flatpakref

Also one common issue that Arch users have is that installing non official packages sometimes breaks the system after cycles of new rolling releases, etc. Flatpak apps are less likely to break due to that.

I don’t think EnOS has any particular stance on this one.
It only reflects the dislike of a subset of EnOS’ users.

Neither. While some individual posters may dislike flatpaks, EndeavourOS has no specific opinion on it either way.

Even if it was installed by default, that difference would still be there.

Flatpak is not planned for any flavor or to be setup in any DE/WM in Endeavour. EOS is a building block for your own computer. It’s intended to be Arch, with yay packaged and a welcome app with a few basic tools. Most things are not intended to be there OOTB - > including flatpak. It’s not a pity, it’s a privilage actually! You only have to add things you want instead of remove things you don’t!

I actually have no real problem with flatpak at all. Outside of Arch, it’s my preffered method of applications.


I also like it on arch in combination with Steam. I really dislike having to use the multilib repos.

And thankfully Arch supports nearly everything! Flatpaks for you AUR for others, Appimages for even more than that! Hurray!

OnePassword and 1Password seem to be two different programs. The latter is available in the AUR: https://aur.archlinux.org/packages/1password

Personally, I think it’s a terrible idea to use a proprietary password manager, but you are free too do as you wish.

I don’t think that’s true in the slightest.

I can, but I certainly won’t! Why would I use Goolag when there exist privacy-respecting search engines?

lol. what a pleasant community. Bye!

People discussing ideas and sharing different opinions shows the strength of a community.

If you don’t agree with someone then that’s fine, but don’t make it out to be an issue with the EnOS community.

1 Like

You simply can’t please everyone.
Still wondering what pissed him off like that.

Perhaps because I disagreed with him? :man_shrugging:

In any case, bye Felicia…

Since the OP is now gone, there seems to no need to continue here.