Flameshot problem on KDE wayland

Well, as I said in the title, I have a problem in KDE with the wayland session, it happens that if I run flameshot there, first there is a kind of weird lag, I get a black screen for 1 second and then the normal flameshot comes out this is one of the problems, the other problem is that normally I save the captures that I make with flameshot in the clipboard, it happens that in the session of wayland worspace-plasma it saves a capture in /tmp/ something fucking weird, and finally I cancel la capture save the screenshot at the address above

None of these problems happen to me in the x11 session, if anyone knows how to fix it please tell me, wayland feels a bit better for normal use and xorg is somewhat insecure nowadays.

Does Flameshot have Wayland support now? Last time I looked it only worked under Xorg…

Works fine under Gnome-Wayland.

 pacman -Qi flameshot
Name            : flameshot
Version         : 11.0.0-4
Description     : Powerful yet simple to use screenshot software
Architecture    : x86_64
URL             : https://github.com/flameshot-org/flameshot
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : qt5-svg  hicolor-icon-theme  kguiaddons
Optional Deps   : gnome-shell-extension-appindicator: for system tray icon if you are using Gnome
                  grim: for wlroots wayland support
                  xdg-desktop-portal: for wayland support, you will need the implementation for
                  your wayland desktop environment [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 2.45 MiB
Packager        : Jiachen YANG <farseerfc@archlinux.org>
Build Date      : Fri 04 Feb 2022 05:51:41 PM CET
Install Date    : Sat 05 Feb 2022 01:49:03 PM CET
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Perhaps this?

xdg-desktop-portal: for wayland support, you will need the implementation for
                  your wayland desktop environment [installed]

:thinking:

Yes, in gnome it worked for me

I already have that installed, in fact flatpak forces me to install it xd

$ pacman -Ss xdg-desktop-portal
extra/xdg-desktop-portal 1.12.1-1
    Desktop integration portals for sandboxed apps
extra/xdg-desktop-portal-gnome 41.1-1
    A backend implementation for xdg-desktop-portal for the GNOME desktop environment
extra/xdg-desktop-portal-gtk 1.12.0-1
    A backend implementation for xdg-desktop-portal using GTK
extra/xdg-desktop-portal-kde 5.24.2-1 (plasma)
    A backend implementation for xdg-desktop-portal using Qt/KF5
community/xdg-desktop-portal-wlr 0.5.0-1
    xdg-desktop-portal backend for wlroots

So, the KDE package (xdg-desktop-portal-kde) ?

1 Like

Yes
imagen

1 Like

the problem
imagen

I don’t want to take 2 captures when I save it to the clipboard with flameshot, I also think it’s the cause of the lag

hm, according to github_flameshot, the support is still experimental for Gnome Wayland and Plasma Wayland.
On Gnome, you would also need to install plugin appindicator-support to see the system tray icon.

Well I just tried flameshot on my KDE plasma and i don’t have this installed.

pacman -Ss xdg-desktop-portal

Why is this needed?

Edit: Taken with Flameshot! :wink:

I see it does take 2 captures but I’m not getting that much of a lag. A little bit i can see.

Are you on wayland or x11? It is only needed for wayland.

I tried it on wayland and it worked without it so i was just wondering. I installed that package now and i really don’t see much of an issue on my system. It works well i only notice it opens a little bit slower if i right click the flameshot icon and take a screenshot. But it’s not laggy it’s just a slight bit slower to open.

Edit: I am comparing it to spectacle.

yeah this lag is only in wayland

It’s needed for Wayland.

Are you on Wayland? I have had to set that up on gnome to make it work as well.

Yes i tried it on Wayland in KDE and i didn’t have that other package installed and it still worked. I really didn’t notice any lag. Maybe a slightly bit slower opening of flameshot but i did install the package and it made no difference either. On my hardware it’s not really a problem. I don’t see much of a lag. It’s noticeable when comparing the two but not significant enough to bother me.

It flat out won’t work at all in gnome if you do some Googling. It has something to do with security in gnome settings. I had to add I to my dock and accept the share before I can use it at all.

Hence why i don’t do gnome. :laughing:

Hence why I don’t use Wayland yet

That too! :laughing:

1 Like