[fixed upstream] Install Bug - reiser in fstab instead of reiserfs

When selecting to create or keep reiserfs partition, installation completes yet partition (/var in my case) is empty because installer incorrectly uses just “reiser” instead of “reiserfs” during the installation and also incorrectly set the /etc/fstab in the new system to the same.

This leaves var partition empty even if corrected in fstab after install and prevents Xorg from loading on first boot. The contents of /var are placed on the / partition instead and I have to copy them manually over to my reiserfs partition.

The installer also incorrectly shows “reiser” which makes it ambigious as to the version being used as well. Unfortunately the bug goes further than the gui.

This is with latest 7-15-2020 release ISO.

UPDATE: This issue seems to be affecting the Installer application that both EndeavourOS and Artix Linux use. The installer apparently updates itself because the Artix ISO I am using is one I previous had and it worked prior. Both of the installers are doing the same in regard to improperly placing only “reiser” into the fstab.

As a sidenote, I’m also receiving an ERROR: A specified local key could not be updated from a keyserver.
This is the same issue I was experiencing when using Artix. The first boot of live cd with EndeavorOS did not do this, yet the second time it did. It should not happen with a live CD.

I am receiving specifically;
“gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10”
This has been occurring to me as well as other users on multiple Arch distros at this point as I’ve seen other users across distros reporting this issue. None of the workarounds have worked for me such as even deleting /etc/pacman.d/gnupg and manually signing does not work.
I am only able to bypass key checking in order to continue with some software installations.

1 Like

The keyserver error is because the SSL certificate for pool.sks-keyservers.net has expired. That is the most common keyserver used by default on Linux and will affect many Linux distributions.

You are correct about the keyserver issue. Using a different one did the trick. What was strange is that the mit.edu pgp server is not working for me either. I was able to use https://pgp.key-server.io instead in order to finally refresh my keys.

You need to use hkps instead of https.

I am aware and I was doing that.

Welcome to the community :beers:
Glad this got resolved for you quickly. Feel free to ask any other questions you run into along the way.

This is truely a BUG i am not sure where it happens may it is this:

could be that parted is using reiser or somehow KPM-CORE is causing this…

BUG reported upstream.

1 Like