First development test ISO for Sway Community Edition installs

First Development version for the Community Edition option.
This is not for real installs of the OS, only for testing, it may do not work properly!

Also @moderators and @admins and the lovely community help us and test it if you want.

https://github.com/endeavouros-team/ISO/releases/download/0-EndeavourOS-development-ISO-releases/endeavouros-devel-CE-2021.02.22-x86_64.iso

https://github.com/endeavouros-team/ISO/releases/download/0-EndeavourOS-development-ISO-releases/endeavouros-devel-CE-2021.02.22-x86_64.iso.sha512sum

to check the file:
sha512sum -c endeavouros-devel-CE-2021.02.22-x86_64.iso.sha512sum

So feel free to test it on real hardware or inside a VM best will be to use qemu based one as Virtualbox have some issues with sway and wayland in general. (virtmanager or Gnome-Boxes)

To start installing Sway Community Edition you have to choose the new Button on Welcome App, it will only work if you are connected to internet and if you do NOT choose Nvidia Driver boot option from booting the ISO:

You can choose a Browser you want to install, if not you will not have one…

And if it gets boring… play a Game:

To give us the logs we need:
cat ~/endeavour-install.log | eos-sendlog from Live Environment or:
cat /var/log/Calamares.log | eos-sendlog from installed system.

both will pastebin the install log and give out a short URL you can post here.
If you find anything not working as it should or you have improvements also.

11 Likes

Installed system.
http://ix.io/2QpN

Mouse needs to be unplugged and plugged back in to work-every boot.
Clicking the keyboard icon in waybar does not bring up the keybindings.
The power button-log out menu on way bar does not work. Click has no return.
Volume icon on waybar does not react to scroll for volume changes. Click still enables pulse settings.

1 Like

i think is not configured that way, it is only a keymap indicator…

this is the same here into qemu… and on real install

…

seems the executable permissions are not set for the scripts folder…

2 Likes

[quote=“Elloquin, post:2, topic:12196”]
Clicking the keyboard icon in waybar does not bring up the keybindings.
[/quote

Setup.sh does not chomod x everything. I know the problem. On my phone tho unfortunately.

Just remove weather.sh and put it to everything.

1 Like

mouse is working fine here

1 Like

I have to dig into it. I have had problems like this all along testing. It’s related to my hardware I think. I am doing another install tomorrow on different hardware.

Yep my fault sorry! Chomd x it all!

Mouse fine for me too. I know @ricklinux has the same issue

1 Like

git clone https://github.com/EndeavourOS-Community-Editions/sway.git
cd sway
cp -R .config /home/$NEW_USER/                                               
chmod -R +x /home/$NEW_USER/.config/sway/scripts
chmod +x /home/$NEW_USER/.config/waybar/scripts/weather.sh
cp .profile /home/$NEW_USER/
chown -R $NEW_USER:$NEW_USER /home/$NEW_USER/.config
chown $NEW_USER:$NEW_USER /home/$NEW_USER/.profile
cd ..
rm -rf sway

changed chmod +x /home/$NEW_USER/.config/waybar/scripts/weather.sh
to:
chmod -R +x /home/$NEW_USER/.config/waybar/scripts

1 Like

@joekamprad do you have this issue?

:alien:
Third reboot mouse works fine USB3
:joy:

1 Like

yes vm and real install

1 Like

missing package pamixer. Sorry! I thought it would be dependecy of PulseAudio.

pamxier

https://archlinux.org/packages/community/x86_64/pamixer/

1 Like
2 Likes

I also had the mouse problem before but will test this iso when I can.

endeavouros-devel-CE-2021.02.22-x86_64.iso
Bare metal install. AMD Ryzen 5 3600G CPU with built in Vega graphics, on B450 motherboard. NVME Samsung 970 Evo Plus - 256 GB. TV with 1360 X768. Erase no hibernation.

INSTALL

I somehow missed where you select a browser, ended up with none. Easy fix.
With 1360X768 resolution, the bottom of one window was behind the bottom panel. I had to go to panel configs and hide the panel as I couldn’t resize the window. I don’t remember which window, but I will duplicate it and insert the image as an Edit.

Post install

Mouse worked fine. First time I logged in, had to unplug and plug in the USB keyboard. Then it worked. Note than I have the keyboard and mouse plugged into a USB hub. So that could be the problem. Subsequent log out and log in and keyboard was OK.
From what little I know about Sway, everything worked including WiFi 5.1
All in all, everything went well in post install.

http://ix.io/2Qr5

EDIT:
here is the window that was too tall for 1360X768. I could change the width of the window, but not the height. That put the buttons bspwm sway and Cancel behind the bottom panel.


I had to Right click on the panel, go to panel preferences and change “automatically hide the panel” to “intelligently”. Then if I was fast I could click on Sway.

The second time I saw where to choose a browser. Blew right by it the first time.

Pudge

2 Likes

Installed Sway on qemu and no mouse. :tired_face: Can’t get around…

Edit: Tried Bspwm and i get Sway again and mouse doesn’t work. Is only Sway available currently and don’t know what to do with the mouse issue on qemu.

That is a yad problem. It has been reported to the yad dev already in October and (an experimental) workaround in the source code is known, but for an unknown reason it hasn’t been fixed yet.

It’s the hardware. Either your mouse or your laptop unfortunately. Plugging in it and out will work but that can get annoying. There’s no issue about this on the sway issuses but I know @Pudge and @Elloquin both reproduced it seems log-in/out and rebooting (three times :laughing:) solved some of it.

1 Like

I feel we should have a note telling the installer to reboot once after installing.