Firewalld not starting on boot

As the title states, no matter what i do, i am not able to make firewalld start on boot.
service is enabled, all the conflicting services are disabled, i can start the service manually.

its working perfectly fine on another system ( arch barebones )
any clue on why this is hapening

Welcome! :smile:

What exactly did you do? Can you show the command(s) and their output?

Did you try this:

sudo systemctl enable --now firewalld.service

Welcome @jojo999 :enos_flag:

sudo systemctl enable firewalld


sudo systemctl enable firewalld.service

Both commands are equivalent. systemctl automatically adds the .service
suffix is not specified. Just pick one.

yea i have already enabled it, you can see in that screenshot that service is enabled. it just doesnt start on system startup

i can start the service manually “sudo systemctl start firewalld” and it works, but enable doesnt work

Check what journalctl says about firewalld after your system start op or see if " systemctl status firewalld.service" gives you any useful information.

Is there any error message when you try to enable?

it is simply what i posted in screenshot of ist comment, no output. service is just dead

no, it executes successfully, like with any other service, if i use --now flag, then it works without any issue, just that on startup its dead again

it simply states that service is dead, nothing else.

no mention of firewalld in journalctl -b either

only firewall related keyword in log is
‘’’ kernel: Bridge firewalling registered "‘’

Are you using Qemu/libvirt on your system?

virt-manager and related packages are installed, yes

Check whether any of these are active on startup.
iptables.service ip6tables.service ebtables.service ipset.service nftables.service
And check if you have the following packages installed: “iptables-nft” and “dnsmasq”?

i did check, all of these services are disabled

but “iptables” and “dnsmasq” are there, is later the problem ?

Do you have any bridge or virtual networks defined in your Qemu/libvirt config and are you able to start them?

i dont have anything defined in my virt-manager, basically never used it, so no

Have you made any adjustment to the firewalld settings, or is it untouched after install?

none i think, except adding an app to firewall

Here’s some reading if you haven’t seen it:

Hope it (or the links in it) helps.