Firewalld loopback connection

1.Fresh EOS system.Loaded this morning. Unfortunately firewalld is showing lo(loop back) connection though it is not added in interfaces. Only wlan0 is added as interface.
How do i get rid of loop back connection in firewalld?.
2.nftables is not storing tables created on permanent basis.If we restart system table disappears.How do i make it permanent?.
iptables and ip6tables are disabled and nftables.service enabled.
Appreciate your help.

This is a recent change in NetworkManager where the loopback interface is now exposed. You probably see it in your network settings as well.

If you look in your screenshot there is a button that says “runtime”. That means you are only making the changes to the running config. If you change it to “permanent” the changes will survive a reboot.

There is also an item in the menu which can copy the runtime config to permanent.

1 Like

I would recommend using the terminal if you want to configure firewalld.
(It is already set up for most users needs by default so most people don’t need to do anything.)

You can make the runtime (current temporary) configuration permanent (meaning it persists through restarts):

sudo firewall-cmd --runtime-to-permanent

The excellent Arch wiki :

This thread is also relevant for EOS :

1 Like

I am afraid you didn’t get my point. Just for screen shot purpose firewalld was kept in run time mode.All changes were carried out using terminal only. All changese of firewalld are in permanent mode.No issues about firewalld except it goes wayward when we create a ipset(again in permanent mode). If we delete ipset, firewalld status changes to running but failed. It saya invalid ipset as error when we use command sudo firewall-cmd --complete-reload
How to remove loopback from firewalld connections
?.Is there a work around?.

Coming to table disappear matter,
I am concerned about nftables. Not firewalld

I have created table with chain,rules.

With root privileges.
nftable can only be configured using root credentials.
Followed redhat guide to create table with chain and rules. works.But disapperas everytime after reboot. nftables.service is up and running

manual changes made though iptables or nftables are not persisted.

You need to create a script to load those rules and then call it via a systemd service.

Have you tried setting lo to unmanaged in Network Manager?

1 Like

I have some how managed setting lo to unmanaged in Network Manager with the help of Redhat documentation. I will try to write a script to store nftables table contents if help available from Redhat Documentation.Thanks for your help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.