Firefox Window Position

I’m not sure if this is an xfce issue or just a Firefox issue, but when I open Firefox it always opens in the top left corner in a smaller that what I last used size. Any help would be greatly appreciated.

We do not ship any preconfigurations for Firefox, it is bare like it falls from the tree.

2 Likes

i think rater its an firefox thing. my setup standard , when i start chromium start i had set , so spread to the edges now changed that in xfwm4-settings not to edges of screen, but now chromium goes to the center, but firefox currently, doesnt. Googled a bit, one tells its a theme issue… but dont think so personally. its not from the last thing, firefox act that way…

I think maybe if you open Firefox and use the refresh feature it will fix it. This will reset Firefox to default settings.

I’m on a tiling window manager so it opens in fullscreen for me. But as an experiment I opened FF in floating mode and then it opens centered on the screen - using approx half the screen space.

i use lxqt but with xfwm4 , only firefox didnt do even i removed the profiles as on some website told…

I’ve tried refreshing Firefox. It’s just weird because some windows save their positions while some don’t.

Don’t have any of that issue on any of the windows. If Firefox is not full screen then yes it does seem to open to top left.

It’s not a bug.

It’s to migitate fingerprinting, by reading your monitors resolution, so when you have that option enabled all Firefox installations will start with the same window size.
—>

1 Like

Ahh… Thank you! Makes perfect sense now.

I do not have this issue on my Cinnamon desktop only on the Xfce. Firefox on my Cinnamon opens up to the size and centered on the screen if i make it smaller than full screen. It does this for ALL windows that open that are not full screen.

Edit: If the window is over a certain size then it does open to the top left. I can get the same on Xfce if the window is small enough it will open centered.