Firefox startup slowed down

Hello there,

I’ve been using EOS for just a couple of days coming from Manjaro KDE. I installed the online version with KDE.

However, I remember Firefox starting up in < 1 second both on Manjaro and the fresh EOS installation. Now, after some tweaking and installing the packages I needed, startup time has increased to around 3.5 seconds. That’s not very long either, but knowing that it once happened much faster than that, it just feels too long :wink:

What I’ve tried so far (with no success obviously):

  • Renamed the .mozilla directory and let it create a new one (I transferred my profiles from Manjaro)
  • Reinstalled Firefox
  • Did some research on the web, where the problem’s usually about addons or DNS. Starting Firefox in rescue mode or without network connection doesn’t help either
  • Installed EOS offline with XFCE on an empty partition, Firefox launches in < 1 second there, with the default profile and my personal profile
  • Started Firefox from terminal and with -P option to select a profile: it takes about 3-4 seconds till the profile selection dialog shows up, starting Firefox after that takes < 1 second

Other applications, like LibreOffice, GIMP, Telegram, don’t have a significant lag at startup. Except for Thunderbird, which also takes around 3 seconds.

The next step I would do eventually is a clean reinstall of EOS online KDE, as I also took most of my Manjaro home directory with config files etc over to EOS. But maybe someone on this forum has some hot suggestions what else I could try out. I would be very grateful for that :slightly_smiling_face: If you need some more information, please let me know.

Best regards,

Did you try creating a new user and logging in with that clean account to see if the issue is still there? That will tell you if the problem is system wide or something to do with your user.

Welcome to the forum :balloon::tada:

Hi, thanks for the suggestion. I’ve just tried that out, no success unfortunately. So it’s probably system wide.

Welcome to EnOS forum!
Enjoy your journey!



Try remove then + 1 by 1 see which slow down firefox ( extensions/addons can slow it down

EDit … :pray: i rude … not welcome you . Welcome to EOS forum

Installing other packages shouldn’t make any difference, but it raises the question of what tweaks did you make?

1 Like

Did you try setting up the localhosts, like it is mentioned in the arch wiki? You wrote you already searched on the internet and found some things related to the stuff in the arch wiki, but maybe you missed this.

@jonathon Manjaro customize their firefox? i see user add manjaro profile ( I just wonder )

That wouldn’t explain the difference between it being a fresh installation with a fresh profile, e.g. starting with -P bypasses the user profile so it’s something to do with the disk (e.g. SSD vs HDD, IO scheduler, background processes, …).

(In any event, the Manjaro customisations are limited to the branding.)

1 Like

i think it just branding . that why i ask you , as you would know . :pray: for fast answer

1 Like

I found out, when one uses dark colos in kde, it slows down firefox startup time
try about:config and set ‘widget.content.allow-gtk-dark-theme’ to true…

1 Like

First of all, thanks for the warm welcomes :grinning:

@I0F Yes, I read about that, but as the hosts file looks right according to the wiki and both files on the working and not-working installation are identical, I dont’t think that causes the issue.

@gjee My GTK Theme ist Materia (not-dark), setting the parameter in about:config didn’t help either. And, afaik, settings in about:config are per-profile as well.

@jonathon As far as disk issues go (NVMe SSD by the way), I remembered another lag and tried something out: When I’m playing a video file with vlc, the interface opens up instantly, and then it also takes about 3 seconds until the video actually starts. So I booted up the clean XFCE installation and played the same file with vlc from the same location - no lag.
On my regular installation, there is lag no matter where the file sits - same behaviour when playing from the XFCE partition or even an NTFS.
When using dragon-player, on first startup it takes about 3 seconds for the interface to show up and the video to play, but when closing the player and re-opening another or the same file, there is no lag, so there might be something running in the background.

I hope this will guide us to a solution and also fix the firefox issue, as both problems seem quite similar :wink:

You must have made some change on your system, so what change did you make?

Thanks for this @gjee it has made a huge difference to my Firefox in KDE. I just looked for the same setting in the config editor in Thunderbird. It is the same, and speeds up Thunderbird’s start up if you are using a dark theme.


some changes on the system I can remember are:

  • Editing fstab to point to my old /home partition
  • Installing Nvidia drivers with nvidia-installer-dkms, which resulted in the system not booting into a graphical environment, so I went back to nouveau by nvidia-installer-dkms -n. On the XFCE system I chose Nvidia before installation, btw. It is a hybrid-graphics notebook with Intel UHD 620 and GeForce MX250.

This is what journalctl -b -0 contains when launching firefox, with dragon player it looks similar: