Firefox on Wayland: Full Screen YouTube Videos Go White

So I’ve been having a minor issue with Wayland where at random times full screen videos on YouTube in Firefox will just become a white screen. What’s odder is the fact that if I wake up the YouTube overlay for the video controls then the video is visible as normal. When windowed the video is also visible.

The hardware I’m using is an Acer Nitro 17 laptop which has a Ryzen 7 CPU (I believe the cpu has an integrated GPU) with an Nvidia 4060 GPU.

Has anyone figured out if there’s a fix or work around aside from not using Wayland or rebooting the system (those are the only work around I’ve found on my own so far)?

Welcome to the community! :vulcan_salute: :enos_flag:

Assuming you are using KDE, please note that both KDE and Wayland give varying results with Nvidia drivers. You may have seen others using Nvidia, Wayland, and KDE and have no issues. They are quite simply lucky. But also, their hardware and packages make a difference.

It sounds like you already know the easiest fix. The other fix I can think of is to use the open-source nouveau drivers for Nvidia instead of the proprietary ones.

That being said, what is the output of:

inxi -FGAz
1 Like

Dual graphics huh. Do you know which one is being used to drive the display?

Here’s the info from the inxi output.

Kernel: 6.9.3-arch1-1 arch: x86_64 bits: 64
Desktop: KDE Plasma v: 6.0.5 Distro: EndeavourOS
Type: Laptop System: Acer product: Nitro AN17-42 v: V1.06
Mobo: HWK model: EX90_HKH v: V1.06 serial:
UEFI: INSYDE v: 1.06 date: 03/06/2024
ID-1: BAT1 charge: 90.1 Wh (100.0%) condition: 90.1/90.1 Wh (100.0%)
Info: 8-core model: AMD Ryzen 7 8845HS w/ Radeon 780M Graphics bits: 64
type: MT MCP cache: L2: 8 MiB
Speed (MHz): avg: 888 min/max: 400/5137 cores: 1: 400 2: 400 3: 2394
4: 1595 5: 1321 6: 400 7: 2230 8: 1340 9: 400 10: 400 11: 400 12: 1331
13: 400 14: 400 15: 400 16: 400
Device-1: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] driver: nvidia
v: 550.90.07
Device-2: AMD Phoenix3 driver: amdgpu v: kernel
Device-3: Chicony ACER HD User Facing driver: uvcvideo type: USB
Display: wayland server: v: with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: amdgpu,nvidia
unloaded: modesetting dri: radeonsi gpu: nvidia,amdgpu
resolution: 1920x1080
API: EGL v: 1.5 drivers: nvidia,radeonsi,swrast
platforms: gbm,wayland,x11,surfaceless,device
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 24.1.1-arch1.1
renderer: AMD Radeon Graphics (radeonsi gfx1103_r1 LLVM 17.0.6 DRM 3.57
API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib,wayland
Device-1: NVIDIA driver: snd_hda_intel
Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_ps
Device-4: AMD Family 17h/19h HD Audio driver: snd_hda_intel
API: ALSA v: k6.9.3-arch1-1 status: kernel-api
Server-1: PipeWire v: 1.0.7 status: active
Device-1: Realtek Killer E3000 2.5GbE driver: r8169
IF: enp2s0 state: down mac:
Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
driver: mt7921e
IF: wlan0 state: up mac:
Device-1: Foxconn / Hon Hai Wireless_Device driver: btusb type: USB
Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: disabled
rfk-block: hardware: no software: no address: N/A
Local Storage: total: 953.87 GiB used: 31.07 GiB (3.3%)
ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFS001TEJ9X125N
size: 953.87 GiB
ID-1: / size: 928.17 GiB used: 30.83 GiB (3.3%) fs: ext4 dev: /dev/nvme0n1p2
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
dev: /dev/nvme0n1p3
System Temperatures: cpu: 31.9 C mobo: 30.0 C
Fan Speeds (rpm): N/A
Memory: total: 16 GiB note: est. available: 14.93 GiB used: 3.67 GiB (24.6%)
Processes: 367 Uptime: 1m Shell: Bash inxi: 3.3.34

How would I get that info?

lspci -k | grep -A 2 -E "(VGA|3D)"

Okay, I have the info now.

01:00.0 VGA compatible controller: NVIDIA Corporation AD107M [GeForce RTX 4060 Max-Q / Mobile] (rev a1)
        Subsystem: Acer Incorporated [ALI] Device 1733
        Kernel modules: nouveau, nvidia_drm, nvidia
65:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Phoenix3 (rev c5)
        Subsystem: Acer Incorporated [ALI] Device 1733
        Kernel driver in use: amdgpu

Two things:

  1. Run this in the terminal:
    pacman -Q | grep -A 2 -E "(nvidia|amd|nouv|mesa|intel)"

  2. When posting it, this time select all of the text and click the button highlighted below:

Thanks, here’s the output.

amd-ucode 20240510.b9d2bf23-1
aom 3.9.0-1
appstream 1.0.3-1
lib32-nvidia-utils 550.90.07-1
lib32-openssl 1:3.3.1-1
lib32-p11-kit 0.25.3-1
nvidia-dkms 550.90.07-1
nvidia-hook 1.5-2
nvidia-inst 24-1
nvidia-settings 550.78-1
nvidia-utils 550.90.07-1
oath-toolkit 2.6.11-2
ocean-sound-theme 6.0.5-1
xf86-video-amdgpu 23.0.0-2
xf86-video-ati 1:22.0.0-2
xfsprogs 6.8.0-2

It seems like your system switches as needed from AMD to Nvidia. I’m wondering why nothing shows for “3D controller”, like this:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
	Subsystem: Lenovo Device 224c
	Kernel driver in use: i915
01:00.0 3D controller: NVIDIA Corporation GP104GLM [Quadro P3000 Mobile] (rev a1)
	Subsystem: Lenovo Device 224c
	Kernel driver in use: nvidia

And why it shows three kernel modules for Nvidia.

Articles of note for reference:
Hybrid Graphics:

Read along with me.

So far, it looks like it may be BIOS related. Does your BIOS have a switch for Nvidia or AMD?

I haven’t checked but I can do that now.

The bios is set to auto-select but if I use the nvidia only gpu with my current install then it just sits trying to load the GUI but when I go to fallback mode it’s fine. Also, when I just go back to auto-select option then it’s back to normal with the non-fallback mode copy.

Since this laptop of mine isn’t my daily driver, I’m going to wipe it with the setting set to Nvidia only and see if that resolves the issue. My hunch is the automatic switching is the problem here. It’s not optimal as a solution but I don’t plan to use this far away from any kind of power source or battery bank. I’ll give an update later tomorrow if this continues with the change over.

Wait. By “wipe” you just mean uninstall the Nvidia proprietary driver and replace it with the nouveau driver, right?

If you meant reinstall the whole system, there is no need for that. Just do the above.

Also, is there an option to use only the AMD GPU or on-board graphics?

I think this is because currently the output shows that it is rendering on the amdgpu so the modules it shows for nvidia are those on the system. If it was rendering on the nvidia it would only show nvidia by saying kernel driver in use “nvidia” This is what I’m thinking. Does that make any sense? :thinking:

Kinda? :sweat_smile:

1 Like

On my desktop with nvidia i have no issues with Wayland playing youtube videos on Firefox in full screen. I do have integrated graphics also on the Intel processor but have it switched off in the bios. :man_shrugging:

Edit: Obviously these hybrid laptops are a different animal to say the least!

Yep. KDE with Wayland just doesn’t work with my GPU. Nor does Sway.

Yet surprisingly, Hyprland does. :person_shrugging:

1 Like

What is your hardware? If Hyprland works then the other should also. :thinking:

Edit: We might be getting off topic here. :wink:

1 Like
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
  Device-2: NVIDIA GP104GLM [Quadro P3000 Mobile] driver: nvidia
    v: 550.90.07
  Device-3: Chicony Integrated Camera driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: intel,nvidia unloaded: fbdev,modesetting,vesa dri: iris gpu: i915
    resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: iris,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.1-arch1.1
    renderer: Mesa Intel HD Graphics 630 (KBL GT2)

What was even more puzzling was that Hyprland worked out of the box with its default settings.

But this is actually okay for me. I wasn’t really interested in Wayland because I don’t need it for anything, and only Hyprland was ever really attractive to me as a reason to want Wayland.

I only tried Sway because I use i3 most days, KDE because that’s my baby :smiling_face_with_three_hearts:, and Cinnamon because that’s my other baby :blush:.

Sway — blank screen;
KDE — kicked me back to login screen;
Cinnamon — worked with minor bugs.