Firefox not playing quicktime videos

My iphone records videos as quicktime *.mov files. When I open such a file in firefox I only get the audio but no video. It looks like it is treating it like an mp3 file.

When I right click on the file and say “download” I can select mpv (my default player) and it opens mpv and plays the video in mpv (or vlc).

As a workaround I tried to tell firefox to open mpv right away when I select a quicktime movie. But hat does not work:

How can I tell firefox to play quicktime videos inline just like it does for mp4 files?

Could it be that mpv doesn’t support those files? try to play a file from the terminal and check the log. Firefox doesn’t seem to have support for it anymore, so maybe you could try another player.

Have you tried it with VLC?

QuickTime is only available on MacOS and Windows anymore with native QuickTime installed.

For Arch based systems, a library exists in the AUR.

This was, but isn’t anymore:

As the former “QuickTime Plug-In for Firefox” has been discontinued, there is an alternative here:

NoPlugin is the missing compatibility layer for modern web browers, allowing you to view most legacy content designed for browser plugins like Adobe Flash, QuickTime, and Windows Media Player. All browsers have phrased out the use of browser plugins, due to performance and security problems, so NoPlugin was created to maintain some compatibility with outdated/archived sites.

NoPlugin searches webpages for embedded plugin objects and converts them into native player elements, wherever possible. If the content can’t be played in-browser (e.g. most Flash embeds), NoPlugin will help you download the file and play it in a separate application.

NoPlugin is open source under the GPL license. Its code is available here:


1 Like

No. Can not be. As I said in my post:

[…] it opens mpv and plays the video in mpv (or vlc).

Repeat: mpv and vlc both play the files.

I understand that firefox does not have a plugin to play quicktime itself. But why is firefox not immediately excecuting mpv (or vlc) if a click on a quicktime movie?

I have a test file in /tmp which clearly identifies as quicktime

# file -i '23-05-01 16-53-44'
23-05-01 16-53-44 video/quicktime; charset=binary

When I enter “/tmp” as the url in firefox I see the file but when I click on it firefox is not opening the video player. Although I told firefox to do so (see screenshot first post).

How can I tell firefox to open the file with an external video player?

I have no issue with Firefox that opens smplayer (based on mpv) when clicking any MOV file after download.


Firefox can open mpv too.

I never changed the default configurations, no media player plugin for Firefox.

Can you please check with “file -i” if the file identifies as quicktime?

$ file -i video/quicktime; charset=binary

Maybe this helps?

You can set this pref to false on the about:config page to prevent Firefox from playing media files via the HTML5 media player. = false

You can open the about:config page via the location/address bar. You can accept the warning and click “I accept the risk!” to continue.

Further possible ways are described here:

You might have to scroll-down on that page a little bit, to the headline:

“Always Open Similar Files” option

…or scroll down and read even further…


This helped in the sense that now, when I click on the file it directly opens mpv. That is good. Thanks.

But what I dont get is, that the firefox configuration in the “Applications” section does not make any difference:

Regardless what I select “Always ask”, “Save as file”, “Use mpv” it does not matter. It always tries to open the file inline.

I guess it is not identifying the file as quicktime but uses the settings for a different file type. I need to figure that out.

I am one step further now. I changed all “Open with …” entries in the “Applications” dialog to “Always ask”. But still firefox opens the file inline.

So I added = false

With that firefox is now asking me what to do with the file. I said “open with mpv” and “do this with all files like this”. Now it is opening mov files with mpv.

And in the “Applications” dialog I see that firefox identifies the file as

I do not know where firefox is taking this mime type from.

But anyways, I leave it for now. It is ok. Thanks for your help. = false

I use = true by default.

But I did not have “QuickTime video” in the “Applications” list.

If I clicked “Always Open Similar Files” :


then I got “QuickTime video” in the “Applications” list.


It opens always mpv when clicking the MOV file.

It may be server related, as server may serve file with bad type in headers - this is reason sometimes files which should be displayed are downloaded. So I guess it can work both ways.

As arch wiki article about Firefox says, you can test video here

This is very interesting thread, showing it used to be possible without plugins

So I guess next step would be to check if Firefox uses ffmpeg, and where does it come and if it was compiled with QuickTime support. If not - here is your chance :blush: