Firefox loads slowly in Wayland

Hi friends.

I moved from X11 to Wayland and I’m having a problem with Firefox.

Firefox randomly loads websites very slowly, sometimes infinitely, and other times it may take 30 seconds or 1 minute.

Sometimes reloading the website reloads the website normally. I’m just using uBlockOrigin, and on X11 it works correctly.

I have searched for information on forums and other sites and have not found a solution.

I know the problem is with Wayland, but I don’t know if it’s caused by it not being supported by my EOS, or by my KDE Plasma, or by my Firefox from the Arch repositories.

Does anyone know what may be causing the problem? Or is it just a Wayland thing, and do we have to wait for the Wayland devs to fix it?

I’m using:

Kernel: 6.9.7-arch1-1 arch: x86_64 bits: 64
Desktop: KDE Plasma v: 6.1.1 Distro: EndeavourOS
Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 555.58.02
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: nvidia unloaded: modesetting
gpu: nvidia resolution: 1920x1080
API: EGL v: 1.5 drivers: nvidia,swrast,zink
platforms: gbm,wayland,x11,surfaceless,device
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 555.58.02
renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib,wayland

Thanks in advance friends.

I honestly have no idea if Nvidia/Wayland would cause issues opening and/or loading sites on Firefox. I’m sure someone with far more knowledge than me will chime in with real advice. Having said that, I’ve not seen that issue before. I can say that on my EOS KDE install on my MacMini with Intel integrated video drivers, I do not suffer any such issues with Firefox.

Have you checked the FF/ Mozilla support forums re: FF speed running under Wayland?

This does not happen on my system. They open instantly. Check the Firefox settings. Are you using a vpn?

set | grep MOZ                                                         
MOZ_ENABLE_WAYLAND 1
MOZ_WAYLAND 1

Have you set the above variables?

This is supposed to automatically be set now on Firefox as far as I know. But i do have a variable set in /etc/environment on mine even so.

https://wiki.archlinux.org/title/firefox#Wayland

Do you have the following kernel boot parameter set in your bootloader configuration?
nvidia_drm.modeset=1

Can you share the output of the following?
# cat /sys/module/nvidia_drm/parameters/modeset

That should give back a “Y”, but if it gives back an “N” you need to add nvidia_drm.modeset=1 to your kernel boot parameters in your bootloader configuration.

https://wiki.archlinux.org/title/NVIDIA#DRM_kernel_mode_setting