Firefox hardware acceleration - artifacts on some webpages


When visiting some websites, Firefox randomly shows visual artifacts - usually in a form of black or white dots. This doesn’t happen very often, but when it does, it gets a little annoying. Chromium on the other hand doesn’t suffer with this issue.

Turning off hardware acceleration solves the problem, but I’d like to find a working solution that will allow me to leave it enabled and handled by Intel graphics.

I configured Firefox according to Arch wiki so at this point I’m out of ideas.

Below is some additional information:

inxi -G

  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: NVIDIA GK107M [GeForce GTX 660M] driver: nvidia v: 470.161.03
  Device-3: Chicony Lenovo EasyCamera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.7 driver: X: loaded: modesetting,nvidia
    dri: crocus gpu: i915 resolution: 1: 1920x1080 2: N/A
  API: OpenGL v: 4.2 Mesa 22.3.4 renderer: Mesa Intel HD Graphics 4000 (IVB

Trying display: wayland
Trying display: x11
vainfo: VA-API version: 1.17 (libva 2.17.1)
vainfo: Driver version: Intel i965 driver for Intel(R) Ivybridge Mobile - 2.4.1
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD

about:support doesn’t throws any errors and shows that I’m using WebRenderer

And here are some modified settings from about:config related to hardware video acceleration:

media.ffmpeg.vaapi.enabled - true
media.av1.enabled - false
1 Like