Firefox cert issues

I have a really odd issue with firefox not accepting digicert certs. if I create a new profile and goto a site that uses digicert like duckduckgo the first time to works fine, however if I close the browser, reload it and go to duckduckgo a second time FF refuses to open the site. I’ve already reinstalled ca-certificates and ca-certificates-mozilla
first attempt:

second attempt:

This is seriously driving me nuts.

Hi @galvez_65,

Did you cleared the cache after reinstalling certificat ?

I don’t know if you use a proxy or not but you could temporarily installed the firefox-developer-edition (currently it is 71.0b3-1) and it will work normally. You are not the only one who has problems with FF 70.0-1 and Digicert issue :

https://bbs.archlinux.org/viewtopic.php?id=247067

You could also downgrade to version 69 in case you need to resolve it fast.

Thanks for help. Not behind a proxy. At lest there is some comfort in seeing others having the same issue. I just installed the firefox-development-edition hopefully that will fix the issue. Hopefully mozilla will fix it in version 71

I just checked that the latest version today is 71.0b4-1.
If it’s the one you installed, tell us if it works.

Apparently, it happens too with FF v70 from fresh Arch install !

https://github.com/clearlinux/distribution/issues/1006

What do you mean if you create a new profile? I am able to bring up the site. What do you have your Firefox privacy & security settings set at? Mine on standard.

Don’t have a solution but thought I’d let you know that I see the same behaviour since I updated to FF v70. Fortunately it seems to go away after some time. One time after a reboot, this morning it may have been down to bad connectivity. Right now everything is working again for me without making any profile changes.

Given that this issue shows only infrequently and fixes itself after some time I didn’t invest time to troubleshoot yet.

create a new firefox profile with profilemanager

yep firefox-developer-edition os 71.0b4-1 thats what I installed and so far it seems to be working

You created a new profile just to see if it fixed the issue? I understand that. I don’t seem to have the issue. I tried to duplicate it but nothing.

Sorry I didn’t get that. The odd thing is I’m only having the problem on one of my computer’s. So it’s definitely not consistent

Sorry. I was just asking if you created a new Firefox profile just to see if it fixed the issue? I’m not having any issues with it. Now I see you switched to the developer edition and that’s working for you.