Firefox 98 released

Thanks for sharing.

I’m using the Official Repository Package of Firefox 98. Any opinions on whether it is better to use the Flatpak package. Any disadvantages for someone who is using Wayland or wants hardware acceleration?

If you are a KeepassXC user, it might get tough. Wayland blocks the Auto-type feature and the flatpak blocks the keepassxc browser extension from connecting to the database. So you’re back to copy&paste :wink:

Unfortunately that’s not how security vulnerabilities work:

FIrefox 98 does not even launch on my RPi 4b 4 GB RAM Running 64 Bit OS KDE Plasma.

I had to downgrade to Firefox 97.0.2. When FF 97 launched, it complained about creating a new user profile. Doing so removed all my settings, bookmarks, etc. I ended up with a blank canvas. What a pain!

Pudge

UPDATE:
Firefox 98.0-1 works on a armv7h 32 bit OS just fine, at least for what I do with it.

Firefox 98.0.1 will not launch on a aarch64 64 bit OS. One needs to downgrade to 97.0.2-1 from
/var/cache/pacman/pkg
using pacman -U

For a new RPi 4 64 Bit install, you can download firefox-97.0.2-1 from my personal website


I had the same thing happen when i downgraded.

1 Like

If that happens, the following terminal command will help Firefox accept the existing profile of the higher version:

firefox --allow-downgrade
2 Likes

The upstream binary or the package from ALARM?

If it’s ALARM, it could be a build chain failure (e.g. it was built against the wrong glibc version).

1 Like

It is from the ALARM aarch64 repository.

Does one run this command before downgrading or after?

Pudge

After downgrading or installing the older version, start the Fox with this command and the old profile will be applied. Delete the empty newly created profile beforehand!

1 Like

It seems that something changed on how files are downloaded. Before the update, if I wanted to read a pdf from an online search, I chose open with Firefox (and it was saved in temp folder or something). Now it opens in a Firefox tab, but it downloads it to my Downloads folder as well.

Do you know a way to change that as it was before?

P.S.: I hate it when they make such unnecessary changes.

must be your settings … like you set to download everytime into Download folder instead of ask for it…

Since the update, all file types where changed to save file. I changed some (pdf included) to always ask and it works. For example (after the update) I click a pdf url, it asks what to do with it, I choose open with Firefox, it downloads on Downloads folder and then opens in a new tab (the now local file).

Prior the update, I think that FF downloaded the file in a temp folder to open it.

EDIT
It seems they no longer use the system’s temp folder.

i only mention this because i am just in a fresh install and firefox do not use Downloads folder and open pdf files from URL open in firefox automatically and do not safe this under Downloads too…

i would bet it uses:
~/.cache/mozilla/firefox/
?

Well, according to the official link above, they now use Downloads folder instead of temp folder to just open a file. I’m not sure why it didn’t change to you. Are you in version 98?

For anyone that want the old behavior (temp folder), go to about:config and set browser.download.improvements_to_download_panel to false. I hope they won’t remove it in the future.

Pdf files open no problem for me online in Firefox. They don’t automatically download. You have to download them manually if you want to save them.

Edit:

Hmm, I’m not sure. I tried your url, I got the popup of what to do with the file, chose open in firefox and opened it from the temp folder (after the fix I posted above). I don’t recall making any special changes to the settings prior to v. 98.

In Firefox 98 mine is set to true. (browser.download.improvements_to_download_panel)

Edit: Also Firefox settings

1 Like

I set the action to “Open in FF” for the pdfs and it now opens them without any download (temp or downloads folder). It seems that the “Open in FF” from the “Always ask” popup works differently.

Thanks.

Here’s a 1 minute (literally) Jack Wallen @ TechRepublic video on this Firefox download change, and how to unset it.

I don’t see any of those options on my Firefox. I’m running version 98.0.2 and everything is fine.