Firefox 92 webrender

Today the latest version of Firefox has been installed on my system (local/firefox 92.0-1). One of the new features it was supposed to offer, is the (now) default rendering engine webrender. As I’m curious, when it’s up to new features, I instantly had a look, if webrender was enabled.

As you can see, it was set to false, which can be easily confirmed in having a look in about:support

So now I knew, that the fallback software mode was enabled (not what I wanted).
I went to about:config and changed the setting accordingly (search for gfx.webrender.all)

After restarting Firefox the new setting was active.

As far as I can tell the rendering of web pages is now faster and much smoother.

10 Likes

Thnx for the info

I have been using Firefox since v2 released

gfx.webrender.all set to true & restart firefox, thats it?

My question is, why isn’t it set to true by default?

Thanks! @Trekkie00 seems to load faster indeed.

Webrender is used in both scenarios (true and false). The difference is, that, if set to false, the rendering is done software based. If set to true, the rendering is hardware accelerated.
My assumption is, that either old settings, from earlier versions are not changed or Firefox does not correctly recognize the capability of using hardware acceleration, so it uses the safe method.

1 Like

Here webrender was already enabled by default since v.91. I would suggest to create a new, clean profile and reconfigure Firefox from scratch, maybe there are some old issues that hinder some things.

1 Like

I’m a big fan of using a user.js file for configurations like this. That way it’s easy to remove and add certain options. For example, here is my user.js for enabling hardware acceleration according to the wiki:

user_pref(“layout.frame_rate”, 144);
user_pref(“gfx.webrender.all”, true);
user_pref(“media.ffmpeg.vaapi.enabled”, true);
user_pref(“media.ffvpx.enabled”, false);
user_pref(“media.rdd-vpx.enabled”, false);
user_pref(“media.navigator.mediadatadecoder_vpx_enabled”, true);

2 Likes

Because depending on your setup webrender can be really broken. I don’t use it due to crashes and rendering bugs

1 Like