Few bugs I'm having on Deepin

Sorry for deleting my last post, but I’ve been able to connect to a wifi network on the control center. I’ve just installed EndeavourOS with Deepin, but I’m still experiencing few bugs I would like to report:

1 - Wifi networks do appear on Deepin control center, but they don’t on the wifi icon (dock)

2 - Power icon doesn’t work, so I cannot shutdown my laptop:

3 - I don’t have rounded corners on the dock unlike the usual Deepin desktop:

4 - Even though I thought I was already connected to my wifi network, since it asked the password, I’m not really connected to it and I have introduced the password correctly:

Is it possible to fix those bugs? Should I go for another DE maybe?

Thanks in advance!

I certainly would suggest that Deepin is not ready for prime time yet! The previous version was largely usable (and looked good) but it is being remade to be more ‘professional’, and the progress is …uneven I guess.

Personally I would use something else, and perhaps set up a virtual system to try Deepin more, and perhaps they’ll get it more ready over time. As for the changeover - I think the wiki (here) has some information on that, or a reinstall always works :grin:

As for which - I would say that XFCE (my choice) and Cinnamon are the most simply usable, KDE is the most configurable (and with effort can be made beautiful) and the others are there to give you choices. Very biased, I’m afraid! Enjoy your time with whatever you choose - and there are people here that can help if you run into something you can’t research your way out of…

1 Like

@anon61999451
Could you post inxi -n

Edit: You may have to install inxi if it’s not installed

Ok, thanks. It’s a pity because Deepin looks great. I tried Ubuntu DDE and I didn’t have issues there, apparently it doesn’t work the same way on Endeavour.

I guess I’m going for either XFCE or KDE then.

This is what I’ve got:

Looks like its Intel wireless 8265/8275 using iwlwifi but it say’s the wifi is not on.

Yeah, but do you think this is due to Deepin DE? Internet worked perfectly during EndeavourOS installation.

It could be the the module isn’t loaded or some other issue? I just wanted to see what chip it was first but if you are going to install another desktop lets see what happens because you might not have an issue.

Probably I won’t have issues on another DE then. In the past I had EndeavourOS with KDE and no issues there. Thanks anyway!

1 Like

I’ve personally never had very good luck on DDE. It’s not to say that others haven’t had better luck. But it’s very hard to diagnose problems on a DE that is prone to having problems. It’s like owning a beautiful Alfa Romeo. It probably will always run, but never quite correctly. But sure does look nice, I must admit.

2 Likes

rfkill list