Fan not running on Endeavouros

I’m running some programs that get the gpus’ temperatures on my laptop very high, but the fan isn’t running. The system is an acer nitro 5 laptop. I think I’ve had this problem on every linux distribution I’ve installed on a laptop with a fan, I just haven’t had it become this extreme before.

When I run sudo pwmconfig, I get the output:

pwmconfig version 3.6.0+git

This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

/usr/bin/pwmconfig: There are no pwm-capable sensor modules installed

and when I run sensors, I get the output:
Adapter: Virtual device
temp1: +55.0°C

Adapter: PCI adapter
Composite: +38.9°C (low = -5.2°C, high = +79.8°C)
(crit = +84.8°C)

Adapter: ISA adapter
Package id 0: +59.0°C (high = +100.0°C, crit = +100.0°C)
Core 0: +59.0°C (high = +100.0°C, crit = +100.0°C)
Core 1: +58.0°C (high = +100.0°C, crit = +100.0°C)
Core 2: +57.0°C (high = +100.0°C, crit = +100.0°C)
Core 3: +55.0°C (high = +100.0°C, crit = +100.0°C)

Adapter: Virtual device
temp1: +50.0°C

Adapter: ACPI interface
in0: 16.95 V
curr1: 0.00 A

Are there certain sensors I should install or is there another solution to this?