Fallout 4, no audio with a twist

So I’m able to run Fallout 4 through Steam with no issues. Since I like to run mods, I use Mod Organizer 2 because it makes more sense to me than Vortex. And I’ve managed to get MO2 working through Steam as well. I’ve read of a number of issues with sound in Fallout 4. And I have an odd one.

It’s the no music or dialogue audio in Fallout 4. But here’s the twist. When I run Fallout 4 through Steam, no issues. When I run Fallout 4 through Mod Organizer 2 or run F4SE through Mod Organizer, I get the bug. The interesting part is that I’m running both Fallout 4 and mod Organizer 2 using the Proton GE compatibility layer. I’ve also run them both using the latest Steam Proton stable build and the experimental. Has anyone encountered the no audio bug before and, if so, how have you resolved the issues?

Thanks for your time.

3 suggestions

  1. Check pipewire settings. With the game running ensure MO2/FO4 are playing through the expected device and the profile is Analogue Stereo Duplex.
  2. Try older proton versions. FO4/MO2 is old enough it may have some of the weird audio dependencies that don’t play as nicely with newer proton versions, wayland, and/or pipewire.
  3. Install a graphical pipewire device routing software, and see if anything shows up on there that you can reroute to a output device of your choosing. I use qpwgraph for troubleshooting this kind of thing, but any of them will do.

Getting audio working is imo the most finicky part playing older games and requires to most per-game configuration (until you reach pre-widescreen games anyways)

Pipewire seems to be working. I get audio everywhere else. This is literally the only game I’ve installed that has this audio problem. Changing MO2 to use another Proton version just causes it to not work.

I did install coppwr to look at the interface graphically. So far as I could tell, everything looked fine, even checking the audio properties of Fallout 4 running via Steam and F4SEloader via Mod Organizer looked the same as one another.

Which leads me to wonder what they original application through Steam has access to that the Mod Organizer 2 doesn’t. Which is odd because I’m running the same Proton wrapper version, so they should have access to the same resources.

Please be specific. You sound frustrated, but directing that towards the forum is not a solution.
Sorry if I’m rude or dismissive as well, I’m a fairly tired and in a fair bit of pain lately. It’s my IT customer service pessimism leaking through.

Which proton versions have you tried? I’m seeing 6 or 7 should be best for MO2/FO4 from protondb. Generally you want to run one of the first couple proton version that went LTS after the game made it big, so the newest GE would not be my go to unless it’s te only one that is functional. Each proton version behaves differently.

Some folks on protondbhad luck trying WINEDLLOVERRIDES=”xaudio2_7=n,b” %command% as a lunch command in steam to run MO2 as well.

coppwr is not the one I would have chosen, the interface is massively more complex than we need, but if MO2/FO4 are connecting to the right outputs as you’ve said that is good. What we are looking for is the program outputs going to the correct playback device, as seen on my music player here:
image
I used to have issues with programs connecting first to monitor ‘outputs’ and never reaching any speakers.

Beyond that… I’m kind of out of ideas. Looking it up… If It’s only dialogue and music try limiting to 60fps, apparently there’s an engine bug that skips dialogue and music at > 60 fps, so try to frame limit with a launch command. Backing up the original then renaming f4se.exe to FalloutLauncher.exe is also suggested as a potential fix.

That’s pretty m uch what I saw. when I used coppwr. Yeah the interface was busy, but the gist of it got through. I compared it to Fallout 4 running nativly in Steam and got the same output in coppwr. So I igured the sound was getting to the correct output. I’ll get the monitor audio thing happening too, but think I have that one figured out.

ATried the override dll thing, didn’t work. I did notice on ProtonDB that other arch users have reported this issue, unfortunatly none of them have reported success in finding a resolution.

The oddest part is that I have audio when I run Fallout 4 in Steam through the Bethesda Launcher. So what does the Fallout launcher use that MO 2 does not. I’ll even get the no sound issue when I run Fallout 4 or the launcher without F4SW. Which is just baffling.

The issue seems to lie within Mod Organizer 2. When I rename the F4SE launch option to Fallout4Luncher.exe I am able to get sound when I run the game through Steam. When I try to run it through Mod Organizer to using the Mod Organizer Fallout 4 Launcher, I stil get no sound. Baffling.

OK, figured it out. The problem is that I was running Mod Organizer 2 in Steam. By running Mod Organizer 2 in Protontricks, I had to select the pfx instance that Mod Organizer would put assets of Mod Organizer into. This post on Steam pointed me towards the answer:

That took an extraordinarly long time. No need to rename anything or do any other unholy things to my installation. Unfortunatley new I believe I need to downgrade the game as I"ve come acroswss black faces and extreme stuttering, which is likely related to the upgrade. I wonder if there is something like the Best of Both Worlds downgrader line in Skyrim SE.

Black faces is due to a texture size mismatch between expected and received. Usually due to the free steam hi-rez texture dlc (I forget the exact name) that increases the face texture size specifically. It breaks almost all body/face texture mids with black face and sometimes even when unmodded too. Disable that and it should be fixed

That would explain why I can’t seem to shake it. I’ve been going through texture mods one after the other. Guess I’ll disable it in the launcher. I found a helpful comment about it which led me to an article that pointed to the answer, but it left out Bethesda’s texture pack being the culprit. Many thanks.

Hmmmm. Upon further investigation it would seem that I do not have that texture pack downloaded. Nor will I download it.

Wasn’t quite done with the bug aspparently. So I found a workaround. Quite by accident. I did a fresh install of both Fallout 4 and Mod Organizer 2. This time, however I installed Mod Organizer directly into my Fallout 4 directory. Installed F4SE manually and when I ran Fallout 4 thorough the regular steam launcher, it launched Mod Organizer 2 rather than the Fallout 4 Launcher. Lo and behold, when I started a new game, the face bug disappeared.

So the root issue with the audio and other bugs seems to be the fact that you have to run Mod Organizer 2 through the virtual filesystem that Steam sets up, otherwise Fallout 4 cannot see the mod manager or it’s associated programs. Now I’m wondering if I can get tools like LOOT to work. I suspect I can if I install them in the Fallout 4 game directory. I did have to download the High Rez Texture pack as the faces wouldn’t display correctly through F4SE otherwise. I hope I didn’t reintroduce the bug again down the line.

I’ve also seen this sound issue crop up with SKSE for those who mod Skyrim Special Edition. I don’t currently have the disk space to mod Skyrim too, the last time I did my load size ran to 400-500 GB. And all I have space for in my Steam library is 1 TB currenly. So I hope people can get some idea of how to proceed from my three days of pain in figuring this out.

Clarification. I installed Mod Organizer 2 into my home directory and put the Mods into the Fallout 4 directory. That seems to be the key here. Before I had the mods saved on a Folder I created on the same drive, but not withing the Fallout 4 game directory. Verify first, then post.