Fails to Boot after Install

Hey All!

So install was successful, no errors were thrown, and I installed the non-NVIDIA one to make sure compatibility wasn’t an issue.
After install, I select from GRUB to boot, and it freezes on:
[drm] radeon kernel modesetting enabled
and doesn’t progress any further after that.
I then attempted the NVIDIA install with the exact same freeze at the exact same spot. I’m not able to get to TTY due to it never reaching the login screen. It’s almost immediately after selecting it from GRUB that it happens.

Specs are:
Intel i7 11th gen
16gb DDR4 RAM
512gb NVMe m.2
Both Intel Xe integrated graphics and an NVIDIA 3060 Super Max-Q mobile GPUs

I’m kind of at a loss right now how to proceed. What am I doing wrong? I’ve attached a picture.

This seems really strange failure point.

I don’t think this setting would break boot, even if radeon drm is wrongly set to Early KMS, while AMD gpu does not exist.

  • How sure are you that you are booting the recently installed system kernel with grub?
  • Did you remove any external drives, or other USB devices, before booting?
  • Try booting to TTY (replace quiet with number 3 at kernel command line, editing grub entry),
  • Are there any other OSes installed on this hardware?
  • Is it a desktop, or a laptop?
  • Is it UEFI, or MSDOS Legacy?
  • Have you ever installed/used any other Linux OS system successfully on this hardware?
  • Have you recently updated/replaced any hardware components on this PC?

It generally looks like a hardware problem. :thinking:

1 Like

Do you have secure boot & csm disabled?

Hi @petsam thanks for responding. Here are my responses
I don’t think it’s a hardware problem because I have successfully installed Endeavour (and many many others) on this machine in the past.

  • I’m pretty sure, actually.
  • I did remove the USB drive that I installed Endeavour from before booting. I normally have the laptop plugged into a dock, but I tried installing with and without the dock plugged in to make sure those weren’t the issue.
  • I’m not quite sure how to boot to TTY without first getting to login screen. I’ll have to look that up in the wiki
  • I do have Pop!_OS installed on here that I was using for school (before semester ended)
  • It’s a laptop
  • It’s UEFI (though Windows is no longer on here. The only OS that exists other than Endeavour is Pop (which Pop was installed first before installing Endeavour)
  • I’ve successfully used almost any Linux OS I’ve put on here. The only one I’ve never gotten to work is Archcraft
  • No, no upgrades.

Thanks for responding @ricklinux

Yeah I tripled checked that they were since I’d found several forum posts about that.

But why would you enable radeon-modesetting as kernel-boot parameter, when there is no AMD graphics on your system?

I’d try removing it or boot with “nomodeset” to see if the system comes up at all. :v:

I did not intentionally enable radeon-modesetting… I did the default installation, and selected the default selection to boot. No tweaking, hacking (as in editing anything and everything), adjusting, nothing. Just booted the live iso, ran the installer, rebooted to the freeze.

If you get to grub, you can hit “e” on the selected boot-entry to edit it to what I told up there before pressing F10, or you can select booting from a fallback GRUB menu entry.

1 Like

I will try that and report back! Thank you!

It’s really strange that it is showing anything amdgpu related. How did you create the live usb?

Yeah I agree, because I have nothing AMD in my machine. :sweat_smile:
I’m using Ventoy, but I’ve always used Ventoy, so I’m not sure what’s changed. I’ve had a Ventoy update since last installing the OS but I don’t think that’d affect anything. Let me try the GRUB entry editing method and see if I can get that to work, and I’ll report that.

That’s the problem right there! (ventoy)

But it doesn’t make sense why it works for any other distro I want to boot, and has worked for 99.99% of the time, and just suddenly stops working? I mean, the live boot works flawlessly. Post install is the issue, not pre.

It maybe is copying things from the ventoy disc? :man_shrugging: I don’t use ventoy because i have seen too many issues with it. I don’t question why? If something doesn’t work I just don’t use it. I’ve never seen the appeal to using ventoy because normally i want the latest ISO so I’m always creating a new live usb.