Failed to unmount /oldroot at shutdown

I know i am not the first person with this issue. I found one thread here but adding shutdown to the hooks didn’t worked for me. I hope someone can help me. I somehow managed to get a picture with all the output. It’s not an important issue but i would like to have a silent shutdown :o

Thanks in advance

What problem are you trying to fix? Is it just to remove some white text that shows momentarily on shutdown but has no other effect on the system?

1 Like

Basically. I just don’t want it to show

System information and a link to the other thread might be useful.

Also keep in mind how much time you’re going to spend fixing something that isn’t causing a problem.

1 Like

Just a sec. Do you need any specific logs?

                   -`                    lighttigerxiv@ARCH-LT14 
                  .o+`                   ----------------------- 
                 `ooo/                   OS: Arch Linux x86_64 
                `+oooo:                  Host: 82JU Legion 5 15ACH6H 
               `+oooooo:                 Kernel: 5.17.1-arch1-1 
               -+oooooo+:                Uptime: 9 mins 
             `/:-:++oooo+:               Packages: 1291 (pacman), 11 (flatpa 
            `/++++/+++++++:              Shell: zsh 5.8.1 
           `/++++++++++++++:             Resolution: 1920x1080 
          `/+++ooooooooooooo/`           DE: GNOME 41.5 
         ./ooosssso++osssssso+`          WM: Mutter 
        .oossssso-````/ossssss+`         WM Theme: Catppuccin-Purple 
       -osssssso.      :ssssssso.        Theme: Catppuccin-Purple [GTK2/3] 
      :osssssss/        osssso+++.       Icons: Papirus-Dark [GTK2/3] 
     /ossssssss/        +ssssooo/-       Terminal: gnome-terminal 
   `/ossssso+/:-        -:/+osssso+-     CPU: AMD Ryzen 5 5600H with Radeon  
  `+sso+:-`                 `.-/+oso:    GPU: NVIDIA GeForce RTX 3060 Mobile 
 `++:.                           `-/+/   Memory: 1533MiB / 7864MiB 
 .`                                 `/
                                                                 
                                                       

The link to the other thread: Failed to unmount /oldroot on shutdown - #13 by cluster

Do you have any nvidia modules included in your initramfs? If so, remove them.

https://bbs.archlinux.org/viewtopic.php?pid=1933513#p1933513

I dont’ have any nvidia module on mkinitcpio:

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=""

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=""

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base systemd autodetect modconf block keyboard keymap consolefont filesystems fsck shutdown"

# COMPRESSION
# Use this to compress the initramfs image. By default, zstd compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="zstd"
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()

Also try this:

And then please provide the journal entries showing the shutdown process so we can see what’s going on.

1 Like

I give up. Nothing works and i am not uninstalling nvidia drivers of course