Failed to start remount root and kernel filesystems

Hi All,

following a fairly large update today, over 100 packages, I started to receive this error when booting. It appeared 3 times and then the login screen appeared. Here’s the entries from my fstab:

UUID=947b8f66-8975-4e0f-b648-1439d7ca8678 / ext4 defaults,noatime 0 1
UUID=ff4d3763-1e51-4161-8a1d-b5d599e0fa6d /home ext4 defaults,noatime 0 2
UUID=7b58095b-917c-47cb-957f-eaaa35fa86a1 swap swap defaults,noatime 0 2
UUID=3ce2888d-b685-4fd4-b155-80d14ea71976 /data ext4 defaults,noatime 0 2

So I did a search on the forum and came up with one match which wasn’t exactly what I was experiencing so I did a search on the internettywebbything and found this:

https://bbs.archlinux.org/viewtopic.php?id=178329

Obviously I understood everything it was describing :wink: but what drew my attention was this entry:

I then # commented out the line for / mounting in fstab and that did the trick!

So I tried this and it worked ! so now my fstab reads:

#UUID=947b8f66-8975-4e0f-b648-1439d7ca8678 / ext4 defaults,noatime 0 1
UUID=ff4d3763-1e51-4161-8a1d-b5d599e0fa6d /home ext4 defaults,noatime 0 2
UUID=7b58095b-917c-47cb-957f-eaaa35fa86a1 swap swap defaults,noatime 0 2
UUID=3ce2888d-b685-4fd4-b155-80d14ea71976 /data ext4 defaults,noatime 0 2

Anyone any ideas?

Rgds
Dave

Can we see the output of the following:

lsblk -o NAME,SIZE,TYPE,MOUNTPOINT,FSTYPE,UUID,PARTUUID
findmnt /

NAME SIZE TYPE MOUNTPOINT FSTYPE UUID PARTUUID
sda 698.7G disk
├─sda1 46.6G part / ext4 38b5b40e-9454-4e9d-a58f-5b7e39a80a11 000117d1-01
├─sda2 1K part 000117d1-02
├─sda3 601.7G part /data ext4 3ce2888d-b685-4fd4-b155-80d14ea71976 000117d1-03
├─sda4 46.6G part /home ext4 ff4d3763-1e51-4161-8a1d-b5d599e0fa6d 000117d1-04
└─sda5 3.9G part [SWAP] swap 7b58095b-917c-47cb-957f-eaaa35fa86a1 000117d1-05
sr0 1024M rom
[dave@laptop ~]$ findmnt /
TARGET SOURCE FSTYPE OPTIONS
/ /dev/sda1 ext4 rw,relatime

Rgds
Dave

1 Like

No wonder you get errors. The fstab contains different UUIDs than the lsblk output shows.
The root / UUID is wrong in fstab.
It should be:

UUID=38b5b40e-9454-4e9d-a58f-5b7e39a80a11 / ext4 defaults,noatime 0 1
1 Like

Yep, looks like your /etc/fstab should have this UUID in it 38b5b40e-9454-4e9d-a58f-5b7e39a80a11

1 Like

You may also need to re-run command:

  grub-mkconfig -o /boot/grub/grub.cfg

if your grub.cfg also has wrong UUIDs.

1 Like

Thank you thank you thank you to all who responded. :grinning: :+1: :clap:
It’s obvious when you know how. I have corrected the UUIDs by copy and pasting all of them from gparted and have recreated grub.cfg. All is now back as it should be.
Rgds
Dave

1 Like