Failed to start Load Linux Kernel Module

At very start of EndeavourOS, I get two lines of the message as mentioned in the title of this post. After a few seconds, the system goes on to proceed normally, landing me at the Login Page. The DE is Deepin. No other problem noticed during further operations. What could be the reason?

systemctl status systemd-modules-load.service

will show you more…
and surely also the boot journal:

lspci > log.txt && lsusb >> log.txt && 
journalctl -b -0 >> log.txt && cat log.txt | eos-sendlog

all in one line will give a short url you can post here

Output of command: "
systemctl status systemd-modules-load.service"

[hrp@Drone ~]$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static)
Active: failed (Result: exit-code) since Thu 2021-01-21 05:49:31 IST; 5min ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 332 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 332 (code=exited, status=1/FAILURE)

Jan 21 05:49:30 Drone systemd[1]: Starting Load Kernel Modules…
Jan 21 05:49:31 Drone systemd-modules-load[332]: Failed to insert module ‘vfs_monitor’: Invalid argument
Jan 21 05:49:31 Drone systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FA>
Jan 21 05:49:31 Drone systemd[1]: systemd-modules-load.service: Failed with result ‘exit-code’.
Jan 21 05:49:31 Drone systemd[1]: Failed to start Load Kernel Modules.

SOLVED.
Uninstalled and reinstalled eandeavouros. First time I had installed online. Second time I installed offline. This time I dropped Deepin and chose XFCE4. And then upgraded online.
Viola! The error is gone. Now it is Deepin or something else, I don’t know. As an ordinary user I have solved my problem as I often do.

1 Like

It is definitely Deepin and has occurred for as long as it has been available in EOS as far as I know. I started using EOS by installing Deepin in a VM, and the error occurred even though everything seemed to work. Eventually, I tried Deepin to metal and the error occurred still. Changed to Budgie and then to Cinnamon which I have been on for a while now. Neither had the issue, not did any of the other non-Deepin desktops (I tried them all ultimately).

1 Like

Please mark it as such.