Failed to start lightdm after first reboot

I’m currently experiencing an issue after first big update and reboot, where lightdm will not start.

Error reads…“Failed to start Light Display Manager”

I’d done a clean install, removed Kalu after some conflicts between Openexr and ilmbase, ran sudo pacman -Syu and then rebooted.

After the reboot, the lightdm error appears. I can login to TTY3 OK by doing Ctrl + Alt + F2, but any attempts to restart the service still fails.

OS team suggested I uninstalled xProfile, but this does not exist in my build.

Can anyone help me, please? I know the OS is working fine, but need to get passed this error.

Thank you!

Run the command
systemctl status lightdm.service

And list the output

If the output says it’s not enabled
systemctl enable lightdm.service

Pudge

EDIT:
I wasn’t very clear, after the Ctrl-Alt-F2 login and run the command.

Still no joy, even enabled!

Hi, could you try :

 sudo lightdm --test-mode --debug
1 Like

What is your GPU driver in use?

1 Like

I’m using a GeForce 210 with NVidia 340xx drivers.

I know this card is no longer supported, but manages to run fine via the Yay installed drivers.

This problem occurred before I’d updated the drivers.

If I can’t find a solution then I’ll have to wait until I’ve got funding for a decent GPU for my desktop.

I’m no expert on this, but one thing to do is to try the nouveau drivers. For that uninstall nvidia drivers and remove any possible settings that would prevent nouveau from running.

Do you have integrated Intel GPU as well? If so, that could be tried too.

Latest Nvidia driver is 340.107 for your card, it seems to be good !
https://www.nvidia.com/Download/driverResults.aspx/135161/en-us

1 Like

Nouveau drivers is causing huge screen tearing issues, which is why I need the 304.107 driver to compensate and allow 74.9Hz on my screen refresh rate.

Do you have nvidia-340xx-dkms driver from AUR?
And one other thing to try is sddm instead of lightdm.

1 Like

Look here :
https://aur.archlinux.org/packages/nvidia-340xx/
The Package Details: nvidia-340xx 340.107-93

In reading the latest comment 2019-11-19 22:20 on this post, it seems to be conflict between 340 driver and kernel 5.3.11…we are on 5.3.12 right now

may help to get the nouveau modsetting driver working well.
compton needs a different way to configure, caused by some changes to compton:
~/.config/autostart/compton.desktop

[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=Compton
Comment=X11 compositor
Exec=compton -b
OnlyShowIn=XFCE;
StartupNotify=false
Terminal=false
Hidden=false

~/.config/compton.conf

backend = "glx";
glx-no-stencil = true;
vsync = true;
unredir-if-possible = true;

# Shadow
shadow = true; # Enabled client-side shadows on windows.
shadow-radius = 7; # The blur radius for shadows. (default 12)
shadow-offset-x = -7; # The left offset for shadows. (default -15)
shadow-offset-y = -7; # The top offset for shadows. (default -15)
shadow-exclude = [
 "n:e:Notification",
 "n:e:Docky",
 "g:e:Synapse",
 "g:e:Conky",
 "n:w:*Firefox*",
 "n:w:*Chromium*",
 "n:w:*dockbarx*",
 "class_g ?= 'Cairo-dock'",
 "class_g ?= 'Xfce4-notifyd'",
 "class_g ?= 'Xfce4-power-manager'",
 "class_g ?= 'Notify-osd'",
 "_GTK_FRAME_EXTENTS@:c"
];

# Opacity
detect-client-opacity = true;

# Window type settings
wintypes:
{
 dock = { shadow = false; };
 dnd = { shadow = false; };
 tooltip = { shadow = false; };
};

I’ve reinstalled the OS and uninstalled Kalu again. I’ve also removed lightdm as my display manager and switched to sddm.

Still getting tearing issues, but I’ve not tried the 340xx-dkms driver yet.

Now you have several possible things to try. Let’s see which one of them work best. :slight_smile:

Thank you, all.

I’ll report back my findings later.

After a few days, I’ve replaced my GPU with a second hand GeForce GT710 that now runs 395 driver. All works well, but screen tearing is still present on some videos. I’ve installed NVidia Settings and disabled all the recommended settings, with little results.

I’m convinced my issues lie within the kernel, as when I use or ElementaryOS the problem goes away.

I’ll wait for the December update before trying again. Thanks everyone!

I also have a nine year old laptop with a Nvidia GPU that uses the 340xx drivers (I only use it for watching netflix etc. in the bedroom) it also shows screen tearing with nouveau.

440.36 is the latest driver…

And xfce also needs some tinkering on nvidia to work without tearing… the default compositor on xfce is causing this as far as i can see…

…and is running with kernel 5.4.

With a GF GT710 you can also use nouveau (as I do). Problems can occur, if software explicitly wants to see certain features of OpenGL in hardware, for German readers: Falkon, Chromium: Freezes, Glitches.

i do run one GF GT710 and one GF GT720
both do not have any issue with latest nvidia driver but the have glitches with nouveau flickering and tearing…