Failed to start D-Bus System Message Bus after trying to install cpupower-gui-git

So I have a very similar issue to the one on this Arch thread:
https://bbs.archlinux.org/viewtopic.php?id=293335

Today I was trying to install cpupower-gui-git but it crashed, black screen and frozen, so I forcerebooted it.

When I try to boot now, I get some “failed to start” System Dbus errors but I still manage to get to the SDDM login screen. However, logging in does nothing (goes to a black screen on Wayland and gets stuck on X11).

I followed the Arch thread by booting into a EndeavourOS liveUSB, chrooting into my disk and running:

sudo LC_ALL=C pacman -Qkk 2>&1 | grep -v ', 0 altered files'

I get a bunch of errors like:

appstream-glib: no mtree file
cowarning: endeavouros-theming: /usr/share/endeavouros/backgrounds (Permissions mismatch)
warning: eos-plasma-sddm-config: /etc/sddm.conf.d/kde_settings.conf (Modification time mismatch)
warning: eos-plasma-sddm-config: /etc/sddm.conf.d/kde_settings.conf (Size mismatch)
warning: eos-plasma-sddm-config: /etc/sddm.conf.d/kde_settings.conf (SHA256 checksum mismatch)

Here is the full output:https://0x0.st/XPFO.txt

The thread recommends to:

  1. Reinstall the packages that lost the mtree first w/ “-S --dbonly”
  2. then again, explicitly w/ -S only
  3. Then attempt an -Syu**

I managed to “fix” the missing mtree packages (they don’t show up anymore in the errors), but I am getting this error when trying to reinstall other packages:
fatal library error, lookup self

I then came across this thread Multiple issues including booting problem, seemingly broken file and fatal library error where the solution was to reinstall all apps using
pacman -Syu $(pacman -Qnq) --overwrite "*"

But this stil gives the same fatal library error.

I also tried sudo dracut-rebuild which worked but doesn’t fix the issue.
Any ideas?