Failed to rate http(s) download

Hii… I’m new in Endeavour os… It’s cool and fast I’ve to admit that.I installed this OS today.

When I click on “Update Arch mirror” Reflector shows that “failed to rate http(s) download”

I’m an Ethernet cable user and the fact is I tried to update the mirrors in my Bootable USB (While roaming in the os)…Where this thing comes “Start the installer”

There I got mirrors working…My internet is working well so it worked on that bootable pendrive but why isn’t it working on my Endeavouros? Is there anything that’s preventing the internet to update mirrors in Endeavouros? Plz gimme solution :pleading_face::pleading_face:

We would need to see the entire error in full to answer that. Some failures in the output are normal but it is hard to tell without seeing what you are seeing.

1 Like

This problem I’m facing while mirror ranking in Reflector…My internet is working good and I’m an Ethernet user:)

This is normal behavior those sites could be down. Thats what ranking is all about. Its only reporting it cant rank those sites as it can’t access them.

It has been like 12 hours+ so those sites are down for so long?:slight_smile:

your putting way to much thought into it just understand you have the best mirrors if you allow the program to finish and write the changes.

It took vs code to download 20 mins from AUR:(

Try rate-mirrors --protocol https arch and see if it works.

If it does, write the output into your mirrorlist:

rate-mirrors --protocol https arch | sudo tee /etc/pacman.d/mirrorlist

You may need to install rate-mirrors first.

Welcome here! :smile:

Looks like your internet connection is slow. What speed are you supposed to have?

1Mbps:))) Minimum… Maximum 2.5-2.7Mbps…

I love you bro… seriously broooo I was feeling so desperate but you came you gave your suggestion and boom!!! It worked!!! Thanks a lot mann!!!

The mirrors aren’t used for this at all. AUR packages are downloaded directly from the source.

Also, are you sure it took 20 minutes to download and it wasn’t building for 20 minutes. Most AUR packages are compiled from source and can take time to build.

Yeah it took 20 mins or 15 Ig…One guy Pekcak or something like that he just replied on this topic and gave me a command it just boosted my internet speed in aur…I downloaded Xanmod Kernel in 1 min:D

That command he gave you has no impact on AUR at all. The mirrors aren’t used for AUR.

Each AUR package comes from a different location.

Right! However some of their dependencies may come from the official repos.

SO for the location I get slower download speed?

Are you sure it was download speed and not build speed?

Yeah cz it was showing Average download speed, Time left, Remaining time etc so Ig it’s downloading thing​:sweat_smile::sweat_smile: I’m having hard time on downloading things in chrome also I called my ISP…They said that they need a few days to fix it:) Ig my ISP prob

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.