"Failed to execute default Terminal Emulator, Input/output error"

When I tried to run the terminal editor emulator after updating a few hours ago, I got that message. I also tried opening up the regular and xfce terminals, but in both cases no window appears.

How do I fix this?

I was about to say, “In a terminal, run the below command”, then I remembered… :laughing:

What is your DE/WM and is it x11 or Wayland?

My DE is Xfce. Don’t know whether that’s X11 or Wayland.

It’s x11, probably. Don’t think Xfce has Wayland support yet, or if it ever will. It probably will, or die?

Try this:

  • In your file manager, go to .config/xfce4
  • Rename the folder called “terminal” to “terminal-bak
  • Go into the folder “xconf/xfce-perchannel-xml
  • Rename the file called “xfce4-terminal.xml” to “xfce4-terminal.xml.bak
  • Try to launch your terminal again

You can either set up your terminal again from scratch or copy some of the settings from the config files. I recommend doing it from scratch, though.

Lastly, if you have any other terminals, follow a similar workflow. Just rename the config folders/files and try to launch them.

It’s getting there - https://wiki.xfce.org/releng/wayland_roadmap

Also Budgie is using libxfce4windowing as part of its ports to Wayland - https://buddiesofbudgie.org/blog/budgie-10-9-released

Nice. Not that I care because I’m not touching Wayland until it stops giving random issues on random hardware. But still, nice. :sweat_smile:

2 Likes

Tried renaming the folders like you suggested, but still can’t get any of the terminals to appear. After restarting my computer the UI for the taskbar, thunar file manager, and windows has changed.

Hmm. What are you doing to try to open the terminals?

Meaning, what are you clicking, pressing, etc?

I’m going into the Start menu and clicking the icons/applications for the terminal/terminal emulator programs.

Seems like you did something different from what I suggested. The xfce4-panel was also in that folder, but I only advised you to edit the terminal-specific file and folder.

Okay. One moment please.
Try downloading the correct file for your device from here: https://github.com/kovidgoyal/kitty/releases/tag/v0.34.1

This is another terminal called “kitty”. You need to pick the correct one, then extract it, and run the file with the name “kitty” found in the “bin” folder.

Alright. I’ve changed it so that it only edited the xfce4-terminal.xml so that its file name reads ‘xfce4-terminal.xml.bak’, but I’m still getting the problem when I try to click on the taskbar icons.

This is how your xfce4 folder should look based on what I advised.


Alright. I’ve downloaded the ‘Linux x86 binary bundle’, extracted it, and run the ‘kitty’ file. This made a terminal window appear.

Okay. Good. So this eliminates the idea that there is some big issue, and narrows things down to a user settings issue.

One moment, please.

Which terminals do you currently have installed? Only xfce4-terminal?

Either way, from the kitty terminal type and run the below command and tell me what happens.

xfce4-terminal 

I happen to have gnome-terminal as well.
In any case, when I try to run both programs, I get the message:

error while loading shared libraries: libicuuc.so.74: cannot open shared object file: No such file or directory

I see now. Effin icu!

Okay. One moment.

Try this and paste the output here:

pacman -Q | grep -i icu

Not sure how to copy from or paste to kitty (keyboard shortcuts and right-clicking don’t seem to work), but the output of that command is:

harfbuzz-icu 8.5.0-1
icu 75.1-1
lib32-icu 75.1-1

Try to do a system update with kitty and paste what happens here if you get any errors.

sudo pacman -Syu && yay

You can copy the output by selecting with your mouse, then pressing CTRL+Shift+C.

While the update didn’t throw any outright errors, I did notice this just after the ‘Starting Full System Upgrade’ message:

warning: glibc: ignoring package upgrade (2.39-1 => 2.39+r52+gf8e4623421-1)
warning: lib32-glibc: ignoring package upgrade (2.39-2 => 2.39+r52+gf8e4623421-1)