Failed retrieving file 'r8168-8.048.03-102-x86_64.pkg.tar.zst'

Hi,
I am trying to update my system but one package r8168 is failing to retrieve.
*
failed retrieving file ‘r8168-8.048.03-102-x86_64.pkg.tar.zst’ from archlinux.thaller.ws : The requested URL returned error: 404*
most mirrors are showing same error.
Please let me know, is this problem system specific or package related and advice how to fix it.

I believe that is not an official Arch Linux, and is a third party site who had a fix on R8168 at one time. Obviously he has removed this particular version of r8168.

You have two choices:
1 Remove r8168-8.048.03-102 and install the official r8168 from the Arch Linux community repository which hopefully has fixed the problem that required the patched version.

2 If 1 doesn’t work, try to contact the maintainer of the rogue r8168-8.048.03-102 to see if he has abandoned the package or is working on a new version.

Pudge

when trying to uninstall
sudo pacman -R r8168-8.048.03-102

error: target not found: r8168-8.048.03-102

pacman -Ss r8168

Does any package come up as “installed”?
If not, then I suspect something else you have installed tries to pull down that file as a dependency.

r8168 is a driver how could that be a dependency to a software.
is there another way to uninstall a driver

If you need to remove it, you just run:
sudo pacman -R r8168
without the version number.

will it stop my wifi too if i uninstall it?

I see it’s there in the repo.

[ricklinux@Archlinux ~]$ pacman -Ss r8168
community/r8168 8.048.03-103
    A kernel module for Realtek 8168 network cards
community/r8168-lts 8.048.03-91
    A kernel module for Realtek 8168 network cards for linux-lts
[ricklinux@Archlinux ~]$ 

Probably at some point.

Can we see the output of pacman -Qi r8168

That should let see how to help you better.

1 Like

I get:

$ pacman -Ss r8168 
community/r8168 8.048.03-102
    A kernel module for Realtek 8168 network cards
community/r8168-lts 8.048.03-90
    A kernel module for Realtek 8168 network cards for linux-lts

:thinking:

Are your mirrors out of date? Alternatively, when was the last time you did pacman -Sy

i removed it and wifi still working.

Currently on Arch so my repos may be updated?

It probably won’t be when you reboot.

Try this:

sudo pacman -S community/r8168
1 Like

This is also from Arch. Gonna refresh the mirrors and try again.

Edit: Strange. Refreshed the mirrors and ran: pacman -Syyu and still get the older version.

@ricklinux @pebcak It doesn’t matter if you are on Arch or EOS, the community repos are the same repos. They come from Arch either way.

2 Likes

i tried this but failed to download
r8168-8.048.03-102-x86_64.pkg.tar.zst failed to download
error: failed retrieving file ‘r8168-8.048.03-102-x86_64.pkg.tar.zst’ f
rom archlinux.thaller.ws : The requested URL returned error: 404

Do i need to refresh mirrors?And if so let me know how to do so.

Did you update your system? Your system needs to be updated before you can install packages. Otherwise your local database will be pointed to packages that no longer are in the repos. I think that may be the whole issue here.

Try this:

sudo pacman -Syu community/r8168

Are you sure? It is on the mirror status page for Arch.

Thanks for helping me out.
@dalto i installed r8168-dkms from AUR
Hope this won’t lead to any problem now.

I stand corrected.

Pudge

1 Like